DNS not appearing on Slaves

OS type and version Debian 10
Webmin version 7.7-3PRO
Virtualmin version 2.021
Related packages SUGGESTED

Ok Gents,

Here is an odd problem, when a new server is created then what usually happens is that its DNS zone gets propagated to all the Cluster DNS servers as a Slave zone.

But instead of that occurring as one would expect, here is what happens instead.

new server created, then DNS zone propagated out to our 3 DNS servers on each it appears but without the TYPE being marked as SLAVE and if I click on the zone it reports

File not found — /bind8/edit_*.cgi?zone=somedomain.com

Then on one of the DNS servers the zone appears as a SLAVE zone as it should with no errors.

If I remove DNS from the virtualhost and add it again then aother of the 3 DNS servers has it setup correctly and the rest again report.

File not found — /bind8/edit_*.cgi?zone=somedomain.com

This to me essentially says that its borked. But I would be wrong.

If I run dig from my desktop against each of the DNS servers in question they report correctly and when I looked into the syslog file the zone is transferring correctly on each server.

This leads me to conclude that perhaps this is a Webmin problem.

What do you think?

Any thoughts as to what might be causing this strange issue?

could it be the firewall
Before doing this, make sure that the slave system does not have a firewall blocking ports 10001-10010, as they are used by Webmin’s RPC calls. The best way to check this and open them up is with the Linux Firewall module, on the slave system. Or you can use the BSD Firewall or IPFW Firewall modules for non-Linux systems.

Ok, I think you may have overlooked the situation as I described.

From my research the zones appear to be transferring, when I look in the logs its all good and if I run a dig query against the slave DNS servers they all respond.

But if I examine Bind from within Webmin it appears correctly on only one slave while the other two report

File not found — /bind8/edit_*.cgi?zone=somedomain.com

Hence I don’t believe that Bind is the culprit here, maybe something in Webmin seems not to be playing ball.

@Jamie would be the man to ask I think.

Another user reported this - it appears to be due to a cache not being updated on the slave server.

Try deleting the file /etc/webmin/bind8/zone-names and see if that helps…

Hi there, well just a belated update, only got to it today and your fix worked a treat, first as a test I renamed the original file and went off to the bind webmin interface and the word slave popped up so back to the directory I went and found to my delight the file had recreated itself. So off I went to the other DNS servers and deleted the zone-names file and sure enough it recreated and this time with the correct type next to the affected zone.

What I would however like to know is what actually causes this to occur in the first place?

Ok I found the cause of this, and it will be fixed in the next Webmin release.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.