Create LE certificate fails

OS type and version RHEL 9.3
Webmin version 2.110

Trying the new option to create an LE cert without a web server.

Webmin, Webmin Configuration, SSL Encryption, Let’s Encrypt.

Request Certificate gets " Failed to request certificate : No virtual host matching was found"

Web server it needed as per docs.

if this is a webmin only system user certbot from the command line if you don’t have a web server installed and then add the cert entry into miniserv.conf, this will give you a https connection without a web server present

This is a new feature in Wemin and I was just reporting that it fails, though I may be doing it wrong too.

“Add an option to request Let’s Encrypt certificates using certbot in standalone mode”

I’m also wondering about this.

I’m trying this directly from the Virtualmin interface and have selected /var/www/html/ as directory but Virtualmin is redirecting port 80 to 10000 for the hostname (which I believe I read in the past might be an issue in terms of implementation).

Perhaps we’re not meant to do it like this, but it’s not quite clear how to do it then.

Edit: worked around this by temporarily moving the .htaccess file in that directory which of course prevent ed the redirect. But in terms of auto renewal this is clearly not workable, so I suppose this is not the way it was meant to happen.

The way i have done it which was prior to the webmin implementation was to use certbot in stand alone mode request the cert and add the live symlink to the webmin config. Certbot then handles updates itself

Don’t hijack the topic with unrelated issues. OP is using Webmin only (I assume), which has a quite different Let’s Encrypt workflow (because Virtualmin systems always have a web server setup in a well-defined/known way).

You should never do anything in /var/www/html in a Virtualmin system. Virtual hosts live in /home. And, you never need to get a certificate for Webmin if you have Virtualmin. You can get a cert for any/all of your Virtualmin domains, and use any of those to connect to Webmin.

If you still have a problem related to Virtualmin and Let’s Encrypt, make a new topic.

This is on a Webmin only system.

Can anybody else try it to confirm if it is a problem?

So you created a virtual host? Not sure what that means with Webmin only install.

Did you try DNS?

Webmin only means without Virtualmin, so I don’t create hosts on this server.

The point is to identify if a new feature is working rather than to use the alternative manual method.

That is in Webmin im showing. To get a cert its either via virtual server in apache config or dns, you have to use DNS if you don’t wont to create a website. Or are they doing it via Webmin server, but that’s on port 10000.

Have a look for yourself.

And then this: Webmin 2.110 and Usermin 2.010 released | Webmin

Add an option to request Let’s Encrypt certificates using certbot in standalone mode

I mistakenly wrote “Virtualmin” because I manage many servers, but for this server it is actually a Webmin instance which only serves DNS. So: no virtual hosts, actually the same situation as Randomz, and no hijacking going on. :wink:

How exactly is the “option to request Let’s Encrypt certificates using certbot in standalone mode” supposed to work?

you are checking the arrowed option ?

1 Like

Ok, interesting, I see the screenshot (always helps) from jimr1.
If its not happening maybe reach out to Jamie.

Thanks. I think that was just added in Webmin 2.111 - and it now works!

1 Like

Interesting, that option to tick doesn’t exist in Webmin 2.111-1 on RHEL 9.3,. but it does in RHEL 8.9 with the exact same Webmin version.

Maybe the clear cache in theme and browser.

Something else at play here as it doesn’t show on any of my other fully up to date Webmin only servers. Centos 7.9, RHEL 8.9 or RHEL 9.3

I will investigate more later.

Make sure certbot is installed on the servers with the missing option . No certbot = no option