Cloudmin KVM server Status SSH what next?

OS type and version Debian12 REQUIRED
Webmin version 2.0.5 REQUIRED
Cloudmin version 9.8? Newest REQUIRED

So I have KVM with a status of SSH I mean I try system operations install virtualmin and I get an error.

I guess I’m kinda lost what to do next.

It would really help if you folks created some video documentation on how to spin up a KVM server and access it the documentation is difficult on this one guys it isn’t like webmin where they have awesome documentation with pictures and so on.

Anyways its strange I just want to boot up a system and login to it when I generate a key for SSH I notice there is no public key when I look at it for cloudmin could this be the issue I’m not really sure but I can’t seem to login to the machine putty just shuts down when I try to login to the IP so IDK maybe you guys can help. Documentation is well… it doesn’t address getting from point A to point B. Virtualmin was a ton easier I’ve tried quite a bit to get things up and running to no avail.

Can you see a terminal if you click System OperationsRoot Shell?

no says something about needing ajaxterm or something along those lines. But you’d think SCP or putty would be able to connect as well if you have SSH status I’m using the image provided by virutalmin a Debian Bullseye image so kinda beats me I would say it is networking but why does it have SSH status if there is no connectivity that is what is leading me to believe cloudmin needs some more work. But yeah I can’t see my server on the rest of the network either which is odd I have ports open I have webmin set to implicitly only accept connections implicitly on my LAN that I would access the server from but thats nothing unusual. Everyone should set up specific IP ranges if your running on bare metal as a security precaution whitelisting works typically with the exception of other bugs which can be caught with other measures. Upon investigating though my network is not showing the IP that the server is on but it could be a scan issue. But the ip is not showing for the bridge network its almost as if my server is on a separate network I can’t access it but yet it can access the net which I what I assumed bridge utilities remediates. Hehe better stop here just thinking out loud more than anything helps when you talk and type gives you another thing or two to think up.

Network Services and Network Services and Protocals are in the unused modules section on webmin not sure if that is the norm or not?

Also DHCP server is also unused I’m not so sure how the bridge and connection works with bridge utilities and what is all a requirement there.

Trying to understand it a bit better because to me following just the documentation don’t get you from point A to point B more or less up and running so I assume it has to do with the update Jamie was talking about releasing but unsure maybe this is something on my side.

Got root shell working but no connection on port 10001 so likely network config issues or branch issues. I’m guessing or firewall issues.

It is odd how I got the status of SSH though but can’t connect so maybe its because I had no owner set with a username and a password as well as a password for root but I think that would be typical root and user account rather than just root for the KVM instance.

Ok so I didn’t setup a virtual interface for my main connection DOH! Just a bridge. However I did something that disallowed SSH status as well likely improper configuration of sorts but I’ll have to take a look into the networking might be where some of my issue lies.

However I will say a lot of the tools and interfaces for file transfer, root shell, vnc view and so on don’t seem to work nor does the installation of virtualmin or webmin so IDK to me its almost like there is packages missing or poor default configuration on the cloudmin interface I mean the VNC viewer and file transfer gives you Java errors and the Root Shell gives you python errors and noVNC is a blank screen.

Does all this stuff work for you? I suppose if there are network configuration errors though its kind of like well that could be a part of the issue. But now I’m sitting at failed SSH logins at the moment going to have to possibly do a reinstall of the OS maybe? IDK hard saying I tried to change the password stull fails to login via SSH and I have port 22 open via the router.

kvm: -vnc :1,password,websocket=5701: warning: short-form boolean option ‘passwo
rd’ deprecated
Please use password=on instead

Strange there is a space between o and r when I copy it I wonder if that has to do with output or if it is in a configuration somewhere with a space on the machine trying to document all possibles to look at here.

Eventually once I get this up and running maybe I’ll make like a pdf with some pictures or something going from A to B spinning up a KVM as to how its accomplished on Debian 12 for folks who want to get involved and see what’s possible. Right now I cant tell if its something I’m doing or something that needs work.

Got this warning on my boot message

Try and connect remotely using a VNC viewer like TightVNC - this is what I use as the web based VNC viewer doesn’t work particularly well :slight_smile:

1 Like

Also note that there is a bug in the port number displayed - it says 5701, but the actual port you need to connect on is 5901.

Yeah that shouldn’t be though it should not say 5701 if it is 5901 if it is a known bug would you not agree it should be fixed ? VNC usually uses ports 5800 or 5801 or 5900 or 5901 I mean I understand this but still things should follow suit.

To me this is a bug because VNC is not limited to standard ports lets say so if a software tells you it is using a different port then it should be accessible via the port it is telling you it might seem like a small problem or not a problem but it is 100% a bug.

The other thing that is troubling is they have 3 different viewers built into cloudmin that DO NOT WORK as far as I can tell. There is a flash based VNC viewer, a java based VNC Viewer, and NoVNC which is an HTML viewer with a javascript library. I mean flash is discontinued is it worth including a flash based VNC viewer in webmin if so why ? It is likely the tools to access the KVM within the cloudmin software need some revamping as well as the tools to transfer files and so on. It almost seems as if there is a lot of dated tools to perform operations and management on the KVM’s.

From a 10,000 ft view what we have here is a software that could be essentially the worlds best hypervisor more or less with a little bit of polishing and not only be the worlds best but the worlds most reasonable and affordable that part is equally important if this part is lost and greed sets in it doesn’t matter how great the software is at the end of the day to me I’m just a small guy with a home lab essentially and there is millions of people like me that fit that bill the guys who want to run a few virtual servers and websites on bare metal and they want to do it in an energy conscious manner without sacrificing performance. So I won’t be running say Debian Jessie on Raspberry Pi’s in a cluster lets say but things are always subject to change I suppose. But the bottom line is the yearly fee’s are where they should be moderately reasonable. What blows my mind is the folks that charge monthly fee’s that are higher than cloudmins yearly fee’s its like come on guys you are contributing to security threats because people are going to run pirated versions of your software from bad actors and put peoples information at risk things such as nulled scripts and what not are also popular because of this. So yeah I mean at the end of the day open source with moderate fee’s keeps things as secure as humanly possible.

End rant but ok good to point out 5701 is NOT the port its standard 5901 ok I’ll have to keep that in mind but I feel its something that should be addressed.

I mean if the 3 viewers included worked well you surely wouldn’t be using tightvnc a program not included albeit a good vnc software that’s well known and been around for some time am I right? Instead you would be using one of the 3 included isn’t it?

As I said, it is a bug.

1 Like

great thank you for affirmation and comments as always :wink:

No problem :slight_smile:

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.