Changing FPM maximum PHP script run time: Apache virtual host was not found - virtualmin 6.16

Operating system: centos
OS version: 7
Webmin version 1.973
Virtualmin version 6.16

Changing maximum PHP script run time to 30 seconds …
… done

Updating PHP directory /home/XXXXX/public_html to version 7.4 …

Failed to save PHP options : Apache virtual host was not found

Hi,

Failed to save PHP options : Apache virtual host was not found

It looks that Apache records for given virtual server were manually removed.

The work-around would be is to go to virtual-server.name - Edit Virtual Server and first disable, save and then re-enable Apache website and Apache SSL website feature.

Hi, it’s not the case. virtual server’s records are present in httpd.conf and re-enable apache support does not solve the problem.
I’ve upgraded and recompiled apache to Apache/2.4.46 for http2 support may be the cause of this issue?
It’s wired because configuration files are not changed and all others virtualmin features works as expected.