Cfs does not send me emails

cfs does not send me emails. I have activated all its notifications but nothing. The mail server is postfix and I have set the ip to I try to put the wrong port in ssh and it blocks me normally. Help please, what should I do to fix it?

Email log for time 14.41

CFS have there own forum for these question, it has nothing to do with webmin/virtuamin.
They have alot more knowlegege then on here. Did you set a email address?
Most prob all the email are in root.
Found this

Yes, I know it, but they did not answer in the cfs forum. I have put the domain’s email. Should I try Mail root?
I have done what the link describes.

By default it goes to root, else you need to add a email address to LF_ALERT_TO =

This is probably the problem but I don’t know what to do…

postfix/trivial-rewrite[33316]: warning: do not list in BOTH mydestination and virtual_alias_domains

That a warning not a error, it shouldn’t cause a issue, it can be fixed as I have seen it before.

I have this in the log mail error, is that it?

May 17 11:49:56 cp milter-greylist: cannot read dumpfile “/var/lib/milter-greylist/greylist.db”
May 17 11:49:56 cp milter-greylist: starting with an empty greylist

You moving away from topic, create a new post for other issues.

1 Like

You can always send application email notifications to the root user, and then forward it using /etc/aliases like root: There’s no need to make this more complicated unless you know exactly what you’re doing, and why.

Moreover, you shouldn’t try to micromanage your firewall operations! Simply don’t configure all those extra email notifications, as it’s absolutely normal for any system facing the internet to see login attempts on all standard ports for all services.

However, you may need to have some notifications get through. For that, just send all mail to the root user and then handle it from there.

1 Like

cfs does not send email to root either. The problem is elsewhere.

Look at csf.conf and check for LF_ALERT_ options set in it. Try this command to fetch what’s configured:

grep 'LF_ALERT_' csf.conf

To send alerts to root, you might want to remove all mentions of LF_ALERT_*.

# Leave this option empty to use the To: field setting in each alert template

In /etc/aliases I have these records. 
# See man 5 aliases for format
postmaster:    root
clamav: root

Where should I write > ??`

I always have a bit of a hard time having discussions in a chaotic manner, sorry. Please go back to my previous comment and share what you have tried. I also answered your question about aliases in my first comment.

Furthermore, use the preformatted text button </> from the edit menu or use Meta + E to wrap code nicely so future readers could easily read it.

cfs only sends email to root mail (root@myhostname) and I want to change that.
Sorry I don’t speak foreign languages…


I put this but it doesn’t send. It only sends to root and I can’t figure out why…

There are many reasons why, considering you have this warning in Postfix logs.

You should write:


and then:

postalias /etc/aliases

You may need to apply changes/restart the service.

I can’t get it to work with the email I want. I’ll leave it to root.

You can edit in the gui here

1 Like

Thanks for the help, I finally made it!

1 Like