CentOS 8 - Postfix virtual maps Issue

Upon installation of Virtualmin on CentOS 8 and running the re-check of configuration. I’m being halted by this error:

A problem was found with your Postfix virtual maps : No map sources were found in the Postfix configuration].

How do I go about resolving this?

Hi,

Thanks for the heads up. What is odd, that it actually should have worked for you out of the box. This is what installer script should do?

Anyway, to fix that, you would want to try to run the following command, which should just work:

virtualmin config-system --include Postfix

If it fails, you would need to make sure that map file exists, and simply add a link to it, as shown on the screenshot below:


Please, let us know what worked out for you eventually?

That command worked! Thanks!

I’m not sure why it didn’t occur in the installation process.I’m on DigitalOcean and I created a few Droplets already and had the same issue each time.

You should have gotten an error if it failed. Are you sure the installation completed? It shows steps and stages, so you can be sure it completes (i.e. you’ll see “Stage 3 of 3” and “[23/23]” (or similar, it’ll be different depending on which mode you’re using) and none of them with a red X?

If Postfix failed, I’d guess other steps failed, too, or didn’t run at all.

You’re right, Joe. I made a fresh installation on CentOS 8 again and do see that it gets cut off on 20/23 because of the PID error.

Check out this screenshot of my Terminal. It looks like Ilia’s screenshot in the announcement post also had the same result as mine.

It’s easily fixable - Virtualmin install.sh support for CentOS 8