Cant install because "Unable to connect" - connection timed out

tried to download the install-script but only get the following error:

“Connecting to (||:443… failed: Connection timed out.”

I tried from several servers in different networks. Mission impossible. Tried to download on my PC (just to see if it works). Same error. No response. Even different VPN allover the world finished with errors.

Anyone has any hint / trick / solution?

Thanks a lot in advance …


Must be a issue with the server at the moment @joe ?

OK. Thanks for the information. Atleast I can stop searching for errors on this / my side and hope that vmin will fix the error.

Seems that they have / had lots of problems regarding downloads (as I read here)?

Thanks for your answer!

Hmmm, now the machine was reachable for some seconds. But couldnt download because “Certificate not valid” (old one)?

Maybe it helps? Webmin Usermin update issue - SOLVED - #8 by ksihota

Repositories are back up ! Should work fine now.

Works for me, and I see no outage in the logs. :man_shrugging:

Any news? Currently I’m trying to install VirtualMin GPL on a new server and this is the result:

staffdi@virtualmin-siti-di:~$ wget
--2023-08-30 09:20:04--
Resolving (
Connecting to (||:443... connected.
Unable to establish SSL connection.

I think this is a new issue.
I can’t download via browser.

It works, browser and wget.

License and version


Short outage by the look, works now

Seems down again ATM (Germany).

same here

It’s up again!

I can’t get Virtualmin updates at this time.

Sorry about that! Please give it another try, as the issue should be resolved by now!

1 Like

It seems that is not up now

E: Failed to fetch Could not connect to (, connection timed out
E: Failed to fetch Unable to connect to

The server is down it seems

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.