Webmin Usermin update issue - SOLVED

OS type and version CentOS Linux 7.9.2009
Webmin version 2.100
Usermin version 2.000
Virtualmin version 7.1
Theme version 21.04
Package updates 2 package updates are available

This is the first time I have ever seen this. Can anyone tell me what is going on?

Refreshed available packages, same error.

Is that still being supported?

PS Virtualmin is now 7.7 :wink: (but not sure if that will make a difference)

EOL 2024. :grimacing:
I have to migrate the server to something else but I keep procrastinating, hoping that someone will come up with an easy, no brainer migration script. :exploding_head:

Not related to this similar topic (different OS) perchance?
or this?

I think there has been a problem with GPG keys recently - thought it was fixed.

Thanks for those links (at least the first one.) I’m looking at them and they appear to be the issue. Just trying to wrap my head around what to do.

I’m having the same issue in :

OS type and version AlmaLinux 8.8
Webmin version 2.100
Usermin version 2.000
Virtualmin version 7.7
Theme version 21.01-2
Package updates 2 package updates are available

Tryied dnf clean packages and clean all with no sucess

I did upgrade my Virtualmin to 7.7
I had to run sh virtualmin-install.sh --setup force-latest to get it.

It didn’t make a difference to the usermin/webin updates. Still the same key error.

I am wondering if I need to run setup-repos.sh that iliajie indicated in that post. This stuff makes my brain hurt. I guess I should have switched to Ubuntu a few months ago. My Ubuntu server is updating without an issue.


I downloaded the latest setup-repos.sh and ran it. I was then able to complete the updates without any errors

1 Like

Awesome it worked here too. thanks

Just to make easier for people to find, the command is:

curl -o setup-repos.sh https://raw.githubusercontent.com/webmin/webmin/master/setup-repos.sh
sh setup-repos.sh

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.