Can I install another webmin on same server?

Please do not laugh at me. This is because I have met so much frustration and don’t have anyone that can help me as I am used to learning from people online but this time no luck.
So I doubt my installation followed correct method cuz each time there is update its really a big issue to update packages.
Now I want to know if I can install another webmin correctly and move my existing production sites to it before I delete the other if thats the case.

Please can one clear me on this?

hi, the answer is no. The best way would be nuke your old server and install it from scratch.

If you need help with it feel free to dm me and have look at my profile. I can help you with it in your timezone.

No. You cannot install a second instance of Webmin (at least not if you’re level of experience is such that you’re having trouble updating packages).

What do you mean by “big issue to update packages”?

And, how did you install? If you used our install script (with instructions found on Downloading and Installing Virtualmin – Virtualmin) and it worked without error, then your installation is not at fault…it would just be a matter of identifying the problem and fixing it.

Er, I guess you’re talking about Webmin and not Virtualmin. If you’re hosting websites, Webmin is not the right tool for the job. You should have a full Virtualmin system instead of just Webmin alone.

I installed webmin and in it you can switch between the two tab. That’s Webmin | Virtualmin

On webmin tab I can easily update webmin by typing in search :mag: Webmin Upgrade which will work immediately I choose update but this is not the case for virtualmin tab or usermin.

Please if you can guide me more closely I can provide my server credentials please.

I have searched on goggle for weeks now with no luck.

I will also like if one can teach me this whole thing about webmin so that I can do things without suffering so much.


I’m not sure how you can miss it. Virtualmin offers to update available system and Virtualmin-provided packages in the dashboard.

This is what I have. I dont really understand if I installed correctly or not. None of the packages update is working currently. It rather outputs error as seen on second screenshot.

That’s not a Virtualmin problem. Nothing you do with Virtualmin will fix that.

I’m not sure why the package manager is treating this upgrade as a new conflicting package.

You should try performing a dnf update on the command line (a proper interactive terminal, not the popup command shell in Virtualmin which is not interactive). See what happens, it may suggest using --skip-broken, which may be worth a try. I don’t know. But, it’s not Virtualmin or Webmin that is broken, so don’t try to “fix” Virtualmin (especially by doing something crazy complicated like trying to have multiple installs of Virtualmin).

1 Like

Sir I want to try your suggestion with PuTTY.
dnf update. I will update you with the output sir.

Sir It outputs same error like below screenshot

Did you try to clear packages cache as suggested? Try running dnf clean all first, may it helps.

Another work around could be is to remove that ImageMagick-lib package, and then re-install it over again. If none of this helps, post the output of the following commands:

dnf repolist


cat /etc/yum.repos.d/virtualmin.repo

@ilia Why would virtualmin repos matter for this error? The offending package is coming from EPEL, not us.

Because some of our packages (Virtualmin and Usermin) are still outdated on the OP screenshot. Although, it may be because that EPEL package error is blocking the whole upgrade. However, Webmin is upgraded to the latest, and that looks odd considering the situation.

OP explained earlier that they manually upgraded Webmin (I guess in the Upgrade Webmin page found through search, even though it is supposed to be hidden on a Virtualmin install…users will always find a way to do something they’re not supposed to!). We are not confused by Webmin being new.

Oh, but, I see that we are not seeing Virtualmin updates available. You’re right. Something is wrong with OPs system.

OP, I’ll ask again, how did you originally install Virtualmin? Did you use our install script? Looks like you maybe don’t have our repos configured…so, either you disabled the Virtualmin repos or you never had them.

1 Like

Below is the output of the command sir
[root@examplesite~]# dnf clean all
73 files removed
[root@examplesite~]# dnf repolist
repo id repo name
appstream AlmaLinux 8 - AppStream
baseos AlmaLinux 8 - BaseOS
epel Extra Packages for Enterprise Linux 8 - x86_64
epel-modular Extra Packages for Enterprise Linux Modular 8 - x86_64
extras AlmaLinux 8 - Extras
powertools AlmaLinux 8 - PowerTools
remi-modular Remi’s Modular repository for Enterprise Linux 8 - x86_64
remi-safe Safe Remi’s RPM repository for Enterprise Linux 8 - x86_64
[root@examplesite~]# cat /etc/yum.repos.d/virtualmin.repo
cat: /etc/yum.repos.d/virtualmin.repo: No such file or directory

I installed through this guide I found on YouTube How to Setup (Contabo) VPS + Free Webmin Panel + Install SSL + Wordpress - Ultimate Tutorial - YouTube 2 years ago but I used another tutorial I found to upgrade from centos to Almalinux.
I dont know if the video guide followed the install script you asked. I really need to do this the right or best way but I dont want to loose my sites on it and other webpages.

Never, ever, ever, under ANY CIRCUMSTANCES go to YouTube to learn how to do something. Nearly every one of them are wrong, convoluted, overblown and will cause you nothing but problems.

All you have to do is go to the install page on Virtualmin and follow three simple steps. No long winded videos to watch. Here are the instructions:

Install your OS. Install the bare bones install. Don’t add ANYTHING. Just run through the basic installer and you’re done.

Run this command: # wget

Run this command: # sudo /bin/sh

That’s it. You’re done. You’ll do that and the only thing left is to run through the post install wizard to finalize your settings.

Then you create your virtual server and go to the built in installer scripts and install Wordpress.

The entire thing should take you less than 45 minutes.

1 Like

I made some videos on YouTube that I think are OK. :wink:

One of those is about installation and configuration (up through the postinstall wizard): Virtualmin Installation and Configuration with CentOS 7 on Vultr - YouTube

But, yes, it’s just going through the steps found on the download page. It shouldn’t take very long, and shouldn’t be very complicated, as long as someone follows the instructions (freshly installed supported OS, fully qualified hostname).

1 Like

This means all my webpages will be gone. Please what can I do to keep my sites. Is it possible?