BIND configuration issue when running Virtualmin

SYSTEM INFORMATION
OS type and version CentOS Linux 7.9.2009
Virtualmin version 7.1

Can someone please help me out with 2 questions?

  1. why does going to this page work (numbers changed for privacy) 222.222.22.222:10000/ but when using the actual domain (centos.website.co:10000/) it does not work? I had to remove the https in front if not I can’t publish this post as there is a limit on 2 links.
  2. Why do I get this error mesage when I try to verify my configuration? How do I fix it?
    (https://i.imgur.com/rjdKSgB.png).

Thanks!

It is strange that you don’t mind sharing the real domain name but are cagey about privacy when sharing the IP address to which the domain is supposed to point. I infer from this that you don’t know much about how DNS works.

Let’s start at the beginning. See:

I am unable to answer question 2 because the link you have provided shows images which are not relevant to our discussion.

1 Like

Hi Sir,

I am trying your method.

Can you help me check if I understood you correctly? I am making the changes in Name Cheap DNS settings.

Is there a reason why I don’t put like use custom DNS like these instead?
ns1.digitalocean.com
ns2.digitalocean.com

Thanks!

The A records look good. You can proceed with installing Virtualmin now on a server with a freshly installed OS.

Could you rephrase that question?

Sir, can you help me with these questions.

  1. Your guide said “After I exit the post-install wizard, for all my clientdomain.tld, I point them to ns1,serverdomain.tld and ns2.serverdomain.tld and create a virtual server with everything set to default for each of the domains I want to host. That is all I have to do.”

Am I doing this part correctly?

  1. how come when users go to http://neutralscents.com/ it is still a blank page?

Thank you

Yup, looks good.

No idea. I don’t see a blank page when I visit the URL. I see in my browser “This site can’t be reached”.

Have the DNS changes that you have made been given enough time to propagate?

Hi Sir,

Yes you are right. I see “This site can’t be reached” also.

Maybe I need to deploy a domain first like in this video? Creating a Virtual Server (Domain) in Virtualmin - YouTube

When I check I see this: https://www.whatsmydns.net/#NS/neutralscents.com
Doesn’t look like it is pointing to the Name Servers I mentioned above?

Thanks

You could call me Niel. The Queen kept forgetting to include my name is her birthday and Christmas lists, so I remain unknighted thus far. Let’s see if Charles III can do any better.

Yes, you need to deploy a domain. Point any domain other than neutralscents.com to your vanity DNS (ns1.neutralscents.com and ns2.neutralscents.com) and then Create Virtual Server in Virtualmin.

But you must wait for DNS propagation to complete, if it has not.

Edit: www.neutralscents.com appears to be resolving… check if you have pointed the naked domain to the IP

Hi Neil,

Can you please help me out with some questions?

  1. I have tried to deploy a new virtual server but I run into errors (highlighted in the red box). Image:

  2. I have also tried to install wordpress using the “Install Scripts” tool but when I try to go to any variation of my website, they all say “site can’t be reached”?
    https:// www.neutralscents[dot]com/
    https:// neutralscents[dot]com
    neutralscents[dot]com
    http:// www.neutralscents[dot]com/
    http:// neutralscents[dot]com

  1. If I have need to connect with my MX, DMARC, SPF records in Zoho mail, do I do this from my domain provider (Name cheap?) Or if I need to set it up on Virtualmin, do you have a guide for that?

Thanks!

This indicates a deeper problem related to the installation of Virtualmin. You need to check the logs to know more.

For neutralscents you need to use the control panel of the domain provider, since the nameservers of this domain are pointed at Namecheap.

For any other domains that you host on your Virtualmin system, by means of pointing them to your vanity nameservers, the MX etc will be managed from within Virtualmin.

Hi Neil, do you happen to have an upwork profile where I can engage you to teach me how to solve this? I want to learn how to do it myself. Right now, I basically have no clue what I am doing.

Hi Niel,

I managed to figure out what was going on. I didn’t have an A record of @ in my Name Cheap registrar.

The issue that I faced of:

Warning : The chroot directory /var/named/chroot that Webmin thinks BIND is using may be incorrect. The zone files for 1 domains could not be found.

Make sure that the chroot directory is set correctly on the module configuration page.

Seems to be encountered by someone else too who didn’t manage to solve it https://issueantenna.com/repo/virtualmin/virtualmin-gpl/issues/292

Any idea how I can troubleshoot this?

Thanks

@ on some dns just a shortcut for the root domain, so if you had a record domain.com A xxxx.xxxx.xxxx.xxxx its the same thing. I’ve never used a @ on the systems I’ve used. Maybe the editor needs a @ to put the root domain in there. I notice cloudflare use it.