After update virtualmin thinks i'm Pro

After using Virtualmin GPL for several years to keep my websites organised, I ran the updates this morning on Centos 7.8 -

virtualmin-config.noarch 0:6.0.28-1
wbm-ruby-gems.noarch 2:1.6-1
wbm-virtual-server.noarch 3:6.10-1
wbm-virtualmin-awstats.noarch 2:5.8-1
wbm-virtualmin-dav.noarch 2:3.10-1
wbm-virtualmin-git.noarch 0:1.10-1
wbm-virtualmin-htpasswd.noarch 2:2.8-1
wbm-virtualmin-init.noarch 2:2.7-1
wbm-virtualmin-registrar.noarch 2:2.7-1
wbm-virtualmin-slavedns.noarch 2:1.10-1
wbm-virtualmin-sqlite.noarch 0:1.8-1

and Virtualmin now thinks i should be pro - giving this message on the Dashboard page:

A problem was detected with your Virtualmin license :
An error occurred checking the licence : Invalid host or serial number A renewal can be purchased at

Any advise please?


it happens to me too…

Same issue here. If i check from terminal (virtualmin license-check) it seems normal. I’m confuesd…

i also try to check on ssh

virtualmin license-info
Serial number: GPL
License key: GPL
Expiry date:
Virtual servers: 50
Maximum servers: Unlimited
Servers left: Unlimited

but on virtualmin panel i see “pro”…

The same happened here

Information before the update

After the update

License information

# virtualmin licence-info
Serial number: GPL
License key: GPL
Expiry date:
Virtual servers: 17
Maximum servers: Unlimited
Servers left: Unlimited

Before the update

After the update

I tried to follow the downgrade steps at and was unsuccessful.

Centos 7 - Fix repo

# nano /etc/yum.repos.d/virtualmin.repo

name=RHEL/CentOS $releasever - $basearch - Virtualmin

name=Virtualmin Distribution Neutral Packages

# yum clean all; yum update

I solved the repository problem, but after updating, the system remains in the PRO version.

Crap. I screwed up. I’m fixing it.

1 Like


After the update it now says that I 'm PRO and i have been limited by the number of email accounts per hosting account and now it doesn’t allow me to see or set the quota for a mailbox. But what the fuck is this?

I fucked up. I’m sorry. I’m fixing it.

Joe, please let us know when you publish the correction, I need to resolve this soon.

You can fix it with:

# yum downgrade wbm-virtual-server-6.10.gpl-1
# service webmin restart

Same issue here

Joe, when you have a stable solution please report here. My clients are very angry.

Did you follow my instructions above? Did something go wrong with following those instructions?

No, only the license message disappeared, but the limitations continue to apply. What a mess!

I’m trying to help and sort it out as fast as I can. I made a mistake. You paid nothing, so, maybe have a little patience while I continue to volunteer my time to help.

I don’t know why limits would continue to apply. Are you sure the GPL version installed?

# rpm -q wbm-virtual-server

If you altered the license file (by running the change-license command), that would also make it think it’s Pro. Make sure /etc/virtualmin-license has GPL for both serial number and key.

And, is there a directory named /usr/libexec/webmin/virtual-server/pro? If so, delete it.


You don’t have to be aggressive. I have not altered anything. It is not my fault that you were wrong. I have some high availability servers even with Virtualmin. Yesterday I could view and edit mailboxes quotas, not today. Apparently the Quotas of the Filesystem were magically deactivated … I 'm checking now

Quotas are unrelated to this issue. Let’s keep the thread on topic. There is already a thread about quota issues…I’ve asked Jamie and Ilia to have a look, as I think maybe quota detection for XFS got broken in this new Webmin.

ahhh nice… very nice :expressionless: