After recent update Dovecot IMAP / POP3 Server stopped working

I am getting the following error when trying to start it:
doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf: Missing ‘}’ (section started at /etc/dovecot/dovecot.conf:107)

I did not touch Dovecot configuration.

And Virtualmin did not start automatically after reboot when one of recent updates of Usermin happened. I had to start it with command: “service webmin start”


That doesn’t look good. However, we believe that all Dovecot issues are sorted out with Virtualmin 6.10+ for new installs and current configs with correct data in it.

What is the output of:

cat /etc/dovecot/dovecot.conf 

… it would be useful to see the config from backups, before the actual update.

Looks like issue happened because I did manual certificate renewal with certbot, and not because of updates.
The end of /etc/dovecot/dovecot.conf is the following:

It should look like this:

local_name {
   ssl_cert = </home/user/ssl.combined
   ssl_key = </home/user/ssl.key
local_name * {
   ssl_cert = </home/user/ssl.combined
   ssl_key = </home/user/ssl.key


I’ve had the same error, I hope it’s not perceived as thread hijacking.

In my case, I didn’t mingle with certbot, however I noticed that the dovecot’s conf file began being messily wrong at a precise point: the part where, approx. a month before the latest update, I manually replaced .cert with .combined, to allow the gmail app to once again receive emails for a domain managed by virtualmin.
(I can find where it’s been recommended, a thread in which I asked if one could use the terminal to try fetching mails, and either Joe or Andrew gave that recommendation, telling it was not a gmail but a virtualmin bug that was on the way of being solved with the next virtualmin update).

And what happened was that a closing bracket } had been “forgotten”, starting at once with the following domain’s local_name { part, and moreover, following this, it would list several different domains altogether for unknown reasons.

I took inspiration from the lines that were before the screwed up part at my line 193, and copy-pasted-replaced to make it look the same, after this, it worked again.

Here’s to hoping it helps, with this advice: copy-paste from the earlier lines that still do work.

(That made me wonder if it would be possible to ask virtualmin to re-create from scratch a dovecot conf file, if needed, it may help in such cases)

Oh boy.

For unrelated reasons, I requested new certificates in letsencrypt for a domain, and after this, I noticed dovecot was down again.

This time I have detailed “evidence” of the maximum mixup that happened in the dovecot.conf file, if it may help, here is what it became afterwards: - it becomes juicy at line 72

(and the nightmare to rewrite the broken parts begins for me, argh. May I humbly ask if it’s obligatory to have the ssl_ca line every time, or only in certain circumstances, like only the mail. subdomain, or domains with mail capability enabled? And is there a way to make virtualmin re-create from scratch a clean, new, proper conf file?)

Get rid of the ssl_ca lines. They are never right. They should all be gone. Really.

Mine became buggered up today with the same issue as eug, must be a bug of some sort. Thanks for posting your resolution helped me!

I am facing the same issue. I did resolve this issue yesterday by manually adding missing “}” where required but today it looks like it has happened again!

I too am getting dovecot.conf corrupted on multiple servers with Virtualmin, missing a } after random host entries. Easy enough to fix by editing the config file and putting the } back in, but annoying as it prevents dovecot restarting.

Also have the same problem, I do use the lets encrypt system and up until recently it has not casued this issue. I will backing up the dovecot.conf manually, and pre fixing it before any reboots now so I can copy it back stright after.

If you’re still seeing a problem with Dovecot with Webmin 1.955 and Virtualmin 6.12, it has to be something different (I think), assuming you read the release announcement and did what was recommended.

Hey Joe, thanks very much for the response. I will double check the above actions have been taken correctly. I expect they have not been. Thanks.

Hey Joe
Thanks for the information to fix the issues. I was missing the closing bracket at the end

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.