Z-Push ActiveSync


just tried to install Z-Push ActiveSync protocol in Virtualmin and I received following error/warning

This script cannot be installed, as this virtual server does not meet its requirements : Z-push requires that PHP scripts be executed using mod_php

So I have 2 questions now:

1: Is there anything more that needs to be configured in order to be able to use ActiveSync on the email
in a virtual server ??

2: the error/warning I posted above, what needs to be configured in my case ? and does these changes
impact other php web sites on this virtual server ??

Thank You


You can enable mod_php by going into Server Configuration -> Website Options, and setting the PHP Execution Mode to “mod_php”.

If there’s anything else within Virtualmin that needs setup, it would warn you about that during the installation.

You may need to log into your Z-Push installation in order to configure it further though.


Hi Eric,

thank You for reply, I will check it and let You know…


the Z-Push is now installed and working just right out of the box NO CONFIGURATION needed !
amazing !! but however I received an error now which is:

An error occurred listing mail in this folder : Failed to login to POP3 server : [UNAVAILABLE] Maximum number of connections from user+IP exceeded (mail_max_userip_connections=10)

I tried to locate the max_userip configuration in Vitrualmin-Webmin but I could not find it…

Where can I increase this number ? I reached it because I tested from different mobile phones…



Virtualmin doesn’t have an error like the one you’re seeing… that sounds like something that may be within the Z-Push application you’re using.

You may want to take a look in the Z-Push application settings to find if you can reset that.


Hi Eric,

are You sure ? this is the error I received in “usermin” when I logged in …
first I get a password question on the mobile phone, than I checked the user login via usermin and when I
logged inn in the usermin instead of the emails in the “inbox” I saw this message:

An error occurred listing mail in this folder : Failed to login to POP3 server : [UNAVAILABLE] Maximum number of connections from user+IP exceeded (mail_max_userip_connections=10)

so if it was something with Z-Push than I would still be able to log-in and read the emails via USERMIN…
but no …

I have also checked the config file in Z-Push and there is no limitations…

I found some posts via google, and someone says that dovecot is configured as default to allow mail_max_userip_connections=10 but I was not able to find this in the dovecot config file…

this is what I have found in the dovecot config file:

A comma separated list of IPs or hosts where to listen in for connections.
“*” listens in all IPv4 interfaces, “::” listens in all IPv6 interfaces.
If you want to specify non-default ports or anything more complex,
edit conf.d/master.conf.
#listen = *, ::

so I am not sure if we can just add this line below these lines above:


any progress on this one ?? I am still having these problems…
please see the screen-shoot image below… and You will understand what I mean …

it seems that iOS (iPhone 4) device open multiple connections what causes this issue…
so I need to configure UNLIMITED connections on the Dovecot

I have found this part of the config in


Maximum number of IMAP connections allowed for a user from each IP address.

NOTE: The username is compared case-sensitively.

#mail_max_userip_connections = 10

so as far as I can see here, the max connections line is commented out which means, not used…
can this be some connection limit pr user instead ??

Any idea ?

Thank You

not sure if this is correct but it solved my problem, I increased with a huge number because I was …

I have added these lines in the following files


mail_max_userip_connections = 5000


mail_max_userip_connections = 5000