Wrong Quota listed

I know this topic has been posted here numerous times, but it didn’t solved my problem.

I’m using the latest Virtualmin and Webmin version and there are running 28 virtual servers.

I’ve mounted the /home to use the quota and I’ve set up all the quota limits. But the Quota panel shows me for each Virtual Server a usage of 56kb, but in reality in there there are some hundred of MB. I’ve already run the quota check several times, but still the same.

But the strange: For 3 users the quota gets listed correctly (root, mainuser and #1000).

This is what I see when I choose a virtual Server and cklich on Edit Virtual Server > Quota…

Home disk space used (including sub-servers) 0 bytes (136 kB by server administrator, 0 bytes by mail / FTP users)
Space used by databases 1.72 MB (1.72 MB in this server, 0 bytes in sub-servers)

Screenshot: http://www.abload.de/img/screenshotkm6t.png

Thanks for your help.

Just to be sure – the files you’re seeing for these users where the quotas aren’t registering anything – are those files definitely owned by those users?

For example, if you have the user “ftp_example”, and there’s 500MB of files in that user’s directory, but they’re all owned by “root”, I don’t believe they would go against the ftp_example user’s quota.


Ok, the works not, the problem was the files where owned by root.

But there is now another problem:

In the User Panel (when im logged in as ftpexample user) I see the wrong quota limit and only the space used by the database. Take a look:

This is what i set up:


And this is what the User sees:



I need help please, just compare these two screens. The user see only the space that the Database takes, but not the /home/user space.

It’s possible they can get out of sync – try going into Limits and Validations -> Check Disk Quotas, and running a check with both “Both users and groups” enabled.


I already did that. Strange thing.

Still no solution for this? Could it be a problem with permission of something or could it be a bug? I did aleady the chown command for each user and that solved the problem from post 1,but it didn’t help here.

I kind of doubt it’s a bug, but it’s hard to say :slight_smile:

Are you sure the files in the home dir belong to the Virtual Server owner?

What do you see if you run an “ls -la /path/to/homedir/”?


I’ve just run that command, here is the result:


I think its OK, or isn’t it?

you can try deleting the quota.user and quota.group files in your /home, then try to enable quotas again, then re-run the configuration check in Virtualmin. Per haps it will pick up.

what’s with the root stuff in your /home ? Should that be there?

that are the permission of some files/folders. Should they belong to another owner or group?


I’ve just tried you “possible solution” but I’m still getting only the size of the database.

I was just wondering why files/folders of root are in /home, they usually are located in folder /root aren’t they?

The root there are just the permissions. I don’t know where thy go normally. But is there a file where i can see which directories he uses to calculate the quota?

Yeah, the quota problem I had is solved now. I’ve installed the 3.70 GLP update. Virtualmin is just the best software. Thank you.


  1. Question:

What is the difference between the soft and the hard limit in webmin and the quota limit in virtualmin?

Which one should get edited?

the soft limit will tell the user he has reached the limit, nothing else will happen, per haps send out an email. He can exceed the limit

the hard limit will prevent the user to exceed the given quota

1 approach to use this is, you could give a soft limit of, let’s say, 50 mb and then a hard limit of 75 mb, where the 50mb could be a warning to the user

Ok, but there is also a Quota limit in Virtualmin (without hard and Softlimit), what about that?

in the virtualmin template you can choose whether you want to use hard limits or soft limits, so it will be whatever you have chosen