WP doesn't find GD module despite it is installed

Centos 6, php 5.3.3, 5.6 and 7.0
Today I created a new Virtual Host and installed Wordpress.
I already have an old WP site in the same server with php 5.3.3
The new installation of WP (I also have set it to use php 5.3.3) doesn’t find a GD installation.
I discovered that when WP asked to crop an image and also when I tried to install a plugin which also needs the GD module.
I posted a WP related question here https://wordpress.stackexchange.com/questions/328318/after-wp-installation-no-gd-lib-recognition-despite-module-is-installed but I guess it is not a WP issue. I could successfully install that plugin in the old WP website.
I am asking here for help because the only thing I remember that could be related to this is that I installed php5.6 and php7.0 recently (via Webmin), after the first WP installation years ago.

With phpinfo(); I discovered that the used php version is 5.6 I don’t have selected in Server Configuration -> PHP Versions.
It is 5.3.3 (and it is the default one in VH templates Edit Server Template - Default Settings -> PHP options -> Default PHP Version = 5.3.3)
I tried to switch to 5.3.3 saving PHP Versions but it still is 5.6
Anyway, there’s no php56-GD in Virtualmin repositories

find -L /home/*/etc/php.ini -xtype l -exec ls -l {}
gives me a list of which php version is used by the existing Vhosts
That old WP installation and this new one ‘have’ php5/php.ini

Edit 1: /home/user/public_html/etc/php.ini symlink points to php5/php.ini not to php5.6/php.ini
VS install was made exclusively from Virtualmin, no manual configuration from shell but WP installation

Edit 2: I delete entire VHost and installed again. phpinfo() -> version 5.6.25 not 5.3.3 as set in template

Edit 3: yum --enablerepo=centos-sclo-rh-testing install rh-php56-php-gd
PHP GD library is installed

have to try to run virtualmin -> system configuration -> recheck config
this will make virtualmin auto detect additional php