Would Someone please help me remove VirtualMin

Hello I have installed Virtualmin and via the install.sh on Centos5

install was fine but I cannot uninstall this thing.

I ran the /bin/sh install.sh -uninstall

and it reinstalls the damn thing again instead of uninstalling it.

Could someone please help me remove this from my servers.


Hi Joe, Try the following
Regards Fallen


This script performs a rudimentary uninstallation of Virtualmin Professional

It is neither complete, nor correct, but it almost certainly won’t break

anything. It is primarily useful for cleaning up a botched install, so you

can run the installer again.

rpm -e virtualmin-release
rpm -e virtualmin-base
rpm -e wbm-virtual-server wbm-virtualmin-htpasswd wbm-virtualmin-dav wbm-virtualmin-mailman wbm-virtualmin-awstats wbm-virtualmin-svn
rpm -e wbt-virtualmin-nuvola wbt-virtualmin-nuvola-pushup wbt-virtualmin-nuvola-green wbt-virtualmin-nuvola-dusk wbt-virtualmin-nuvola-raspberry wbt-virtualmin-nuvola-chocmint ust-virtualmin-nuvola
rpm -e webmin usermin awstats
yum clean all

Hello Fallen,

Thanks a ton for the reply

Is there anything in your post that is commented out that I need to uncomment in the scripts such as this


Should I run what is below this or uncomment this first? Like so



this is the uninstall script that i have used in the past

It is run as is above


Hello Fallen,

I tried the script and Virtualmin is still installed. Looks like I am going to have to reinstall the OS. That really sucks.

Thanks a ton for your help I do appreciate it.


Did you manage to uninstall it?


Well, that post was from a few years ago, but it should actually be pretty straight forward to remove Virtualmin… you can use the same install.sh script you used to perform the initial installation if you’re looking to remove it.

You can run:

./install.sh -u

And that will uninstall Virtualmin.

There’s also a document describing that here: