Wordpress site blank page of death after migration

SYSTEM INFORMATION
OS type and version: CentOS
Webmin version: REQUIRED
Virtualmin version: REQUIRED
Related products version: RECOMMENDED

After migration from cpanel backup into virtualmin the wordpress site went blank page of death. Tried many things but none of them worked.

I also tried to execute sql from cpanel backup’s mysql folder into newly created mariadb database in order to import it and it gave "doesnt exist "errors:

ERROR 1146 (42S02) at line 1264 in file: ‘/home/mysite/mysql/mysite_wp11.sql’: Table ‘mysite_wp11.wp_posts’ doesn’t exist

How to fix?

Which version was your MySQL and your MariaDB? You can’t just drop-in the latest/later versions of one over the other anymore now.

Save your time.

He doesn’t even have a domain. He has no access to anything but an old backup. When you tell him to “upload his Wordpress files” he goes ahead and uploads his old phpmyadmin files and over writes all of that as well.

First of all thanks for helping.

MariaDB version: 5.5.68
phpmyadmin : 5.1.1
PHP versions installed: 7.0.27, 7.3.29, 7.4.24

I think the importing mysql database into mariadb couldnt finish successfully because i dont see the wp_posts tables and you know it gives error while uploading tables

You can’t just download a MySQL database and upload it to MariaDB (anymore). Check the discussion on this other thread for more information on migrating from MySQL to MariaDB.

Is that means i have to use mysqldump? but i cant open any links on website. For example even mysite.com/phpmyadmin gives blank page/HTTP500.
So is there any alternative way to do it?

Then there are issues not related with databases as well in your server.

Yeah it probably seems a server related issue. But i still couldn’t figured out.
When extracting files/folders from cpanel tar.gz backup file i only copied public_html folder into newly created and wordpress installed virtual server.

Should i also copy any other files/folders from cpanel backup to the virtual server?

Here is the latest apache error log lines:

[Mon Sep 27  2021] [negotiation:error] [pid 16610] [client ] AH00687: Negotiation: discovered file(s) matching request: /home/mysite/public_html/index.html (None could be negotiated)., referer: https://www.mysite.com/
[Mon Sep 27  2021] [cgi:error] [pid 16610] [client ] AH01215: PHP Warning:  Unknown: failed to open stream: No such file or directory in Unknown on line 0, referer: https://www.mysite.com/
[Mon Sep 27  2021] [cgi:error] [pid 16610] [client] AH01215: PHP Fatal error:  Unknown: Failed opening required '/home/mysite2/public_html/wordfence-waf.php' (include_path='.:/usr/share/pear:/usr/share/php') in Unknown on line 0, referer: https://www.mysite.com/

Have u seen and realize the “mysite” and “mysite2” on the paths above?
So that sounds like wordfence or server has been configured to look into an old directory name. But i have no idea on php warning and negotiation errors above that .

Edit1: Now i renamed the directory to old one and the site starts giving "403 forbidden " error.

Sounds like there are more than one issue in your server indeed. I could check the server config for you if you want. Just send me a personal message here and I can set up a session for you.

ok i sent you a pm.
after renaming the top level directory to old cpanel’s one, i start getting "403 forbidden "errors. I tried to change permissions but none worked.

here is the new apache error logs:

[Mon Sep 27 2021] [authz_core:error] [pid 5259] [client ] AH01630: client denied by server configuration: /home/mysite, referer: http://www.mysite.com
[Mon Sep 27 2021] [authz_core:error] [pid 5432] [client ] AH01630: client denied by server configuration: /home/mysite
[Mon Sep 27 2021] [authz_core:error] [pid 5243] [client ] AH01630: client denied by server configuration: /home/mysite

so it seems now the virtualmin rejects the new name of the directory…

@serverfaul do you know what you are doing? latest your post within errors you have is telling you how to troubleshoot this… I don’t understand why are you trying to be handspooned here…this issue should be closed by moderator or administrative personnel.

1 Like