Wordpress Login not working

So i installed Wordpress script, and the mydomain.com/wp-login.php link gets “The page isn’t redirecting properly.”

I have the script installing at the top level to avoid having mydomain.com/wordpress be the home page.

SYSTEM INFORMATION
OS type and version Ubunutu 20.04
Virtualmin version 7.1-1

Could you post the relevant log / error log entries?

Also see

The suggestions in the link get better as one progresses through the article.

I have tried the url form a completely different system and get the same error. I am installing WP from the script and only change is to install at top level. The script says to click on the link to finish the install but the link is just to the domain, and not the install or login php links

Well, if you want a kludge for this, use Virtualmin → Website Options and then in the “Website documents sub-directory” field, enter “wordpress” to change the document root to the location of the WordPress install that works on your system.

If you do this, domain.tld/wordpress will show on domain.tld

Just installed on Vultr with ubunutu 20.04 and trying a WP install with a test domain I use, works fine.

Try going to example.com/wp-admin instead (where example.com is your website domain) and see if that redirects you accordingly.

That’s the wrong link.

mydomain.com/wp-admin

So when I instal the script, this is the final on screen log that shows…to me…this indicates that the script is showing the wrong link….the link in parentheses doesn’t show on screen…so-admin is a directory, not a login form

Now installing WordPress version 6.0.1 …

WordPress installation completed. It can be accessed at https://mydomain.com/.

More information on using this script can be found at http://wordpress.org/.

The initial administration login is cits with the password p@$$word .

… done

Re-loading Webmin …
… done

That’s all you need to type. mydomain.com/wp-admin. The login posts automatically. It’s worked that way since Wordpress was created.

If you get an error, it’s probably a “too many redirects” error which means your SSL isn’t configured properly.

wp-admin redirects unauthorized users to wp-login.php which has always been the login page for wordpress. so /wp-login.php should always work. (also through /wp-admin).

OP should post apache access|error.log to see details on redirect error.

You’re missing the point.

If he gets the error typing in the login.php FILE that could be a missing file or any other number of issues. If he just uses the wp-login ADDRESS that will tell you if he’s having an SSL issue. It will send anybody who enters it to the login provided the install is working properly. Being “authorized” has nothing to do with it.