Wordpress installed but URL Not Found On Server


I installed Wordpress on one of my Virtual Servers and it installs successfully. But when I click on the Install & Configuration link provided by Wordpress, it says The requested URL was not found on this server.

Any help will be highly appreciated.


In fact, that holds good for all scripts I install.

Hello Pranab and welcome to the community.

Did you install WordPress via Virtualmin’s Install Script option or did you install it manually - by uploading WordPress and running the installer?

In which directory / folder do you install scripts?

Hi @calport,

I installed it using the Virtualmin scripts.

The installed directory is /home/dev/public_html (domain name is dev.domain.com)

Can anyone help? It’s really strange, that the scripts install with no problems, but the URLs error out.

Did you select the option to install on the public folder, or did it install on it’s own folder?.. Go to the File Manager of the domain and see where it’s installed…

I followed your link at [dev.domain.com](http://dev.domain.com/] and it’s not showing the VM welcome page either… Is the domain in?..

I’m guessing it shows installed in your File Mgr…Can you delete the entire sub and start again?.. Before you install WP, call the sub and see what you get… I’m sorry, but I’m confused on your set up. I tried calling the domain swisslearning.com and it redirected to https://mytestlab.space/…

I have tried deleting the scripts multiple times and re-installed, but no luck. And this is not just with Wordpress. It happens with any script I try to install. It installs successfully, but when I click on the configure link, it shows 404 Not found.

The mytestlab is a redirect (I’m unable to find). Have removed it from every possible place in the DNS and within wordpress databases.

By deleting sub, do you mean deleting the sub-domain and try all over again?

When I call the sub-domain, it shows the default apache2 page. And yes, it all files show properly installed in the public_html folder

I’m sorry I can’t be anymore help… I have no idea how your VM is configured, and I have no knowledge of Ubuntu…

If you wish, I could login via screenshare (Anydesk or something) and take a quick look at your setup.

1 Like

Hello @calport . Sure. What is the best way to get in touch?

Phone, WhatsApp, email… whatever you like, Pranab.

Sure. I have messaged you on the number ending with 1274, that I found on your website.

Pranab and I have connected directly. We have thereafter agreed upon a way forward so please treat this topic as closed.

Post script: on his install of Virtualmin that I accessed remotely, PHP files were being downloaded. I changed PHP execution method in Virtualmin but the issue persisted. I then opened another browser and the PHP file rendered the web page normally. Strange: in one window the same url offered for download a PHP file and in another window it was rendering the web page normally. A cache issue, perhaps, but a strange one.

Cal, it’s funny you said that. The server I had issues with, the one I deleted, had the same problem. All PHP pages would download instead…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.