Wordpress Install Script - Every url under your domain should redirect to a 404 page of your website not the 404 page of your server

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.6 server
Webmin version Webmin 2.111
Virtualmin version Virtualmin 7.10.0
Related packages Install script 54.115.91 for wordpress-6.5.2.zip

Wordpress was installed on 21-Apr-24.

Next, I installed Divi Version: 4.25.0 which is claimed to be “The Most Popular WordPress Theme In The World And The Ultimate WordPress Page Builder”

The ‘Sample Page’ on the new website of the Divi theme has a link to the freshly created Wordpress Dashboard. Clicking this link in Firefox returns

Not Found - The requested URL was not found on this server.

The default Wordpress theme, ‘Twenty Twenty-Four’ has a ‘Sample Page’ which also has a link to the Wordpress Dashboard. Clicking on that link in Firefox returns the same error

Not Found - The requested URL was not found on this server.

Next, I installed a Wordpress plugin, Adminer “Manage the database from your WordPress Dashboard using Adminer Version 2.2.2 By Pexle Chris”

Clicking on the link to open Adminer in Firefox returns the same error

Not Found - The requested URL was not found on this server.

I’ve done nothing to the website except install Wordpress and Divi and later Adminer. A second website without Adminer behaves the same so I don’t think Adminer has broken Wordpress. A third website without Divi or Adminer behaves the same.

The developer of Adminer, Pexle Chris [Christos Pechlevanoudis], tells me “wp-adminer is a fake link like all the links in the front-end.” He researched the error and believes

“The problem is that in your website the fake [link] have not been set properly. Every url under your domain should redirect to a 404 page of your website not the 404 page of your server.”

Is Pexel Chris correct?

Apparently Wordpress handles this ‘fake link’ in some way to open the actual location of the plugin? I guess the ‘Sample Page’ links to the Dashboard are the same kind of ‘fake link’?

The URL error occurs with a fresh install of Wordpress and Divi and Adminer. Is the problem in Ubuntu or Wordpress or the Virtualmin Install Script or me?

Thank you for your efforts.

Are you using nginx?

Off topic alert.
Have a look at bricks builder, I love it.

It look like phpMyadmin, are you only using it to access the database? If so just install that script if it breaking things, works outside WP though.

Never heard that term before. Have you tried resaving or setting your Permalinks

I’m using Apache version 2.4.41

Thanks for replying. I’m just installing Wordpress for the 1st time on a few new sites. To try to simplify the problem I tried your suggestion on a new site with only Wordpress and the default website. To reset Permalinks I followed advice here

It had no effect I can see. Links to navigate the default site work but the one link to return to the Dashboard still returns # Not Found The requested URL was not found on this server.

I will ask again as you didn’t answer are you using nginx webserver ? If so you have to configure nginx to do the rewrites. If your using apache as a web server i would look at your .htaccess file for errors

1 Like

They did answer. They’re using Apache. I asked as there was a bug with the nginx config for some install scripts (fixed in the current Virtualmin version, though, I think).

Maybe ask them how is it fixed as I’ve not clue about setting fake [link].
Every Wordpress install I’ve done has worked fine.

I’ve been working on this issue with other people over some days and I’ve decided that it is likely not an issue with Webmin, Virtualmin, Wordpress or Adminer. I’m guessing the issue is with the operating system, hardware or other software. This is a new server installation on a dedicated box from a hosting provider at a Phoenix datacenter.

Over the years I’ve built several Ubuntu servers using different hosting providers. Some have been excellent performers and others have been troubled. Every box seems different. I’m not a computer pro and I never know exactly why. Sometimes, the dog just won’t hunt. It may be the dog or it may be me. Sometimes, the easiest solution is to get another dog. So I’m finished fooling with this server box on this issue. I doubt I’ll ever know exactly what was wrong. I just got another server box over the weekend and I’m going to build a new server on that and see how it goes.

Thank you for your advice and thank you for giving my issue your attention!

After I posted that I gave up fixing the server PexleChris volunteered to fix it. All he had to do was install an .htaccess file in the public_html directory. He says it should have been installed automatically by Wordpress. Unfortunately, PexleChris didn’t have full access to the server so he couldn’t see why Wordpress still is not adding the .htaccess file to the new Wordpress websites I generate with the Virtualmin Install script. It may be I’ve broken the server in some way by installing Xubuntu Desktop after Virtualmin and before Wordpress. I’m still guessing the first issue is with the operating system, hardware or other software so I’m going with my new dog to use Wordpress. Thank you PexleChris!

According to PexleChris

"The problem was your Apache web server and its configuration file .htaccess that was missing. I have placed it and now works fine.

the htaccess should have been generated automatically for each of your websites, it’s native WordPress feature.

You can read more here: Apache HTTPD / .htaccess – Advanced Administration Handbook | Developer.WordPress.org"

contents of .htaccess file in the website public_html directory today …

# BEGIN WordPress
# The directives (lines) between "BEGIN WordPress" and "END WordPress" are
# dynamically generated, and should only be modified via WordPress filters.
# Any changes to the directives between these markers will be overwritten.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress
1 Like

It’s either a gremlin in the system or an accidental delete, both happen sometimes. I’m glad all worked out for you

are you using nginx or apache as a web server? If your using nginx there is extra
configuration to be done in the nginx config files, but if you are using apache check your .htaccess file in your public_html folder

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.