Wordpress fails for /wp-admin but OK for homepage

Ubuntu 22.04.4
Webmin version 2.111
Virtualmin version 7.10.0 Pro
Related packages Worpress

Two new installs of WP using the pro script fail due to “too many redirects.” Going to the homepage is fine, the error is for visiting example.com/wp-admin.

I am using Cloudflare with all account and zone permissions open (edit for zone and dns).

Go to SSL in cloudflare and set it to full or strict

It maybe virtualmin and cloudflare are both handling ssl certificates I think.
There maybe more if you search the forum. I’m sure Ive seen this come up.

Thanks, I set cloudflare to full and it said the error was my certificate. Went to Virtualmin to setup Let’s Encrypt and got this error:

  • Apache website : An IPv6 DNS record www.trafficloadermarketing.com with address 2606:4700:3031::6815:1c1e exists, but this virtual server does not have IPv6 enabled

I went to virtualmin>addresses and networking>change IP address and can not see where to set ipv6 for apache. Where would that be?

I am on contabo with an ipv6 assigned.

I see where I can set ‘Ranges for IP allocation’ in Server Templates. I don’t understand how to set my ranges. But how do I set ipv6 for an existing server?

For now, as a workaround, you need to skip validation before requesting a new Let’s Encrypt SSL certificate.

Thanks for that.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.