WordPress/Drupal needs to access your web server

OS type and version Ubuntu 20.04
Webmin version 2.021
Virtualmin version 7.7
Related packages SUGGESTED

I run a virtualmin setup with 50+ WordPress and Drupal websites, since today for some reason I can’t seem to update drupal modules or delete wordpress plugins without providing SSH/FTP creds.

the error is;

Connection Information

To perform the requested action, WordPress needs to access your web server. Please enter your FTP or SSH credentials to proceed. If you do not remember your credentials, you should contact your web host.

I have no idea what is going on… I have check file permissions, but that looks fine to me.

Anyone has encountered this before?

I have seen the workaround by adding this line to wp-config.php.

define(‘FS_METHOD’, ‘ftpext’);

But I’d like to find the root cause and address that instead.

I have found the root cause;

For some reason a PHP update changed all my php script execution modes to FCGId coming from FPM.

I’m actually not sure this was the root cause, everything works now, however I see that the php.ini location is different, so I believe it was set to FCGId afterall… but it works on FPM and not on FCGId. Anyone ever experienced something similar?

Just set up an new virtualmin server and transfered one website. Everything works on FPM and CGI.

Even though everything works on FPM. I’m eager to find out what happened. Anyone with more experience here? :innocent:

Hi, I can have a look at old server and logs - forensically but task is not for free and its time tedious ergo = £25 per hour I would say. Otherwise you fixed the issue with re-installing virtualmin and cut the issues in shortest. Enjoy.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.