With "output_buffering = off" Error 503 Service unavailable

If I activate the setting output_buffering = off for Joomla (domain / Web Configuration / PHP_FPM Configuration) the server gives me the error 503 Service unavailable.

As far as I’m concerned I can keep it On, but I’d be curious to know what’s bothering it.
In “Apache Error Log” I find these two lines:

[Date & Time] [proxy_fcgi:error] [pid X:tid Y] [client IP:32756] AH01079: failed to make connection to backend: httpd-UDS
[Date & Time] [proxy:error] [pid X:tid Y] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/php/171205142861615. sock (*:80) failed
OS type and version Debian12
Webmin version 2.105
Virtualmin version 7.10
Related packages Apache - PHP

That looks like the service (FPM or fcgid+php-cgi) fails to start, which makes me think you’re introducing invalid syntax into the configuration file.

I didn’t change the configuration, but I just added the line “output_buffering = off”.
Should it be written differently?

Last person to accept an answer from here. :wink:

But, the default is off. So, this is strange. Maybe just try and comment out the ‘on’ line. That said, unless the scripts are tiny, it seems buffering allows you to start responding before the default action of waiting until the script finishes. So, turning it off may not do what you expect?

;   On = Enabled and buffer is unlimited. (Use with caution)
;   Off = Disabled
;   Integer = Enables the buffer and sets its maximum size in bytes.
; Note: This directive is hardcoded to Off for the CLI SAPI
; Default Value: Off
; Development Value: 4096
; Production Value: 4096
; https://php.net/output-buffering
output_buffering = 4096

Could this also be a problem of where you put this line in the config?

I changed it on the page “domain / Web Configuration / PHP_FPM Configuration”.
Now I tried editing the php.ini directly and it seems to work.
So, I didn’t understand when to use that page.

I just posted recently I ran into the ‘which php.ini’ decades ago. So, don’t know. Seems the domain specific over rides ‘should work’, but see the disclaimer of the first sentence of my first post.

My best guess it is an all or nothing for the server and not something that can be overridden on an individual basis.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.