Windows install nightmare

Installing other OS such as Centos has been breeze but Windows is pain as usual. I cannot connect to VNC at all.

Here is my config file for windows


memory = 1024 maxmem = 2048 name = 'windows' vif = [ 'ip=,mac=00:16:3e:A9:9E:C6' ] address = '' netmask = '' disk = ['file:/xen/windows.img,hda,w','file:/home/user1/Win2k3SrvEnt.ISO,hdc:cdrom,r'] boot = 'dc' kernel = "/usr/lib/xen/boot/hvmloader" builder = "hvm" device_model = "/usr/lib64/xen/bin/qemu-dm" acpi = 0 vnc = 4 vnclisten = "" vncpasswd = "password" usbdevice = 'tablet' ______________________________________

Looks like Xen has a built in VNCSERVER? or possibly scripts that get executed only when a vnc session is attempted. I tried restarting service vncserver restart to see if it picks up vnc = 4 but

Starting VNC server: no displays configured [ OK ]

So hinting that VNCSERVER is not the same as XENVNCSERVER.

Can some one please help and educate me as to what is wrong? All I need is to install Windows but for that I need to connect to the some sort of X display

I have tried this

and this

and googled on VNC windows issues!!

Kindly help :slight_smile:


found the solution but don’t understand why it is listerning on :19. For those having issues run the following command

netstat -an | grep vnc

it should give you similar output and check for which number the session is running on. mine was :19

root 3521 0.0 0.3 92180 4596 ? Sl 08:58 0:06 /usr/lib64/xen/bin/qemu-dm -M xenpv -d 1 -domain-name node1 -vnc,password -vncunused -k en-us
root 3695 0.0 0.0 92180 896 ? Sl 08:58 0:00 /usr/lib64/xen/bin/qemu-dm -M xenpv -d 2 -domain-name node2 -vnc,password -vncunused -k en-us
root 3889 0.0 0.3 92180 4676 ? Sl 08:58 0:00 /usr/lib64/xen/bin/qemu-dm -M xenpv -d 3 -domain-name node3 -vnc,password -vncunused -k en-us
root 18341 0.0 0.4 92316 5824 ? Sl 10:46 0:00 /usr/lib64/xen/bin/qemu-dm -d 19 -m 1024 -boot dc -vcpus 1 -usbdevice tablet -domain-name windows -net nic,vlan=1,macaddr=00:16:3e:A9:9E:C6,model=rtl8139 -net tap,vlan=1,bridge=xenbr0 -vnc,password -vncunused
root 19853 0.0 0.0 61220 812 pts/7 S+ 11:18 0:00 grep vnc

can some one please explain this?

Thanks :smiley:

interestingly now it is running on :20

root 20350 33.9 0.4 92316 5836 ? Sl 11:25 0:03 /usr/lib64/xen/bin/qemu-dm -d 20 -m 1024 -boot dc -vcpus 1 -usbdevice tablet -domain-name windows -net nic,vlan=1,macaddr=00:16:3e:A9:9E:C6,model=rtl8139 -net tap,vlan=1,bridge=xenbr0 -vnc,password -vncunused
root 20521 0.0 0.0 61220 812 pts/7 S+ 11:25 0:00 grep vnc

I was disconnected from 19 as soon as formatting the drive was done and windows graphical installer started. doing netstat -an revealed vnc is now listetinging on :20

I believe (but I’m guessing based on KVM behavior) that Xen has its own VNC server, so vncserver in your case would just be getting in the way (I think). Which would explain why your Xen instances are getting oddly high ports.

But, that’s all a guess. I’ve never tried to install Windows in a guest…but I know some folks have. I think Scott (user sgrayban here in the forums) has successfully done so. Maybe someone who has done so will chime in.