Will upgrading CentOS 7.6 to 8.2 break my install?

About to upgrade…going to make an LVM snapshot…but I figured I’d ask. Running latest Virtualmin 6.10 as well as latest Webmin 1.953 and Usermin 1.802. Thanks!

Go with fresh install, droplet/instance Centos 8.2, install virtualmin and simply do “Backup and Restor > Restore Virtual Servers”

wget http://software.virtualmin.com/gpl/scripts/install.sh
sudo /bin/sh install.sh

2 Likes

Once done, point domain to new IP (DNS)

Personally, assuming that some downtime is acceptable, I’d plant backups in at least two places (like S3 AND Backblaze), install CentOS, update it, install Virtualmin, and restore. I’ve never had a lot of joy trying to do a version upgrade on the OS once any panel is installed.

Otherwise, do it as a migration like @ricoshocks advised. But plan it. Set the TTLs in DNS on the losing server really short – like 600 – for at least a week, point the DNS on the losing server to the gaining one once it’s working, and leave the losing server in service until it’s getting no more traffic. That helps prevent client-side caching issues.

Because all my clients are in the States, however, I usually just do these things at night with prior warning about the downtime. They rarely take more than a couple of hours, and the legit traffic is virtually zero at night. It’s all hackers, crackers, and miscreants on the graveyard shift.

Richard

1 Like

Thanks for the tips, guys. I got this error on backup:

backup of mysql failed : mysql::execute_sql failed : DBI connect failed : Access denied for user ‘root’@‘localhost’ (using password: YES)

I changed my root password for MySQL manually after install. Maybe Virtualmin is pulling an old password from some config file?

If you change your mysql root password, you need to tell Webmin (in the MySQL module). There is no way for it to find it out if you don’t tell it. The password is encrypted.

1 Like

How do I go about this process? Thank you for the pointers on this!

I found the location. Webmin -> Servers -> MySQL Database Server. It prompted me to set a root password right as I entered that page.

So I ended up exporting the virtual servers okay. When I went to restore my virtual servers, I got this error:

Failed to create virtual server : Failed to find section local_name [MYDOMAINNAMEHERE.COM] !

I applied this GitHub fix supplied by Ilia in another thread:

Applying those two new lines to ‘/usr/libexec/webmin/dovecot/dovecot-lib.pl’ (CentOS 8.2) fixed the error and now my websites are restored.

I believe the file is located at ’ /usr/share/webmin/dovecot/dovecot-lib.pl’ for Ubuntu 20.04 systems.

Thanks!

1 Like

I had the same issue. Failed to create virtual server : Failed to find section local_name However, you can do a work around. Just create the server without SSL, and when done re-add the SSL certificates and hit save…sometimes had to do it twice, yet worked for me.

1 Like

Really great to know. Thanks for that @ricoshocks.

Ok, so now when I go to System Settings -> Re-Check Configuration, I get the following error:

AH00526: Syntax error on line 394 of /etc/httpd/conf/httpd.conf:
Invalid command ‘php_admin_value’, perhaps misspelled or defined by a module not included in the server configuration

I realized httpd wasn’t running. When I try to start it, I get this:

Jul 28 21:36:40 fqdn.mydomainname.com systemd[1]: Starting The Apache HTTP Server…
Jul 28 21:36:41 fqdn.mydomainname.com httpd[1024]: AH00526: Syntax error on line 394 of /etc/httpd/conf/httpd.conf:
Jul 28 21:36:41 fqdn.mydomainname.com httpd[1024]: Invalid command ‘php_admin_value’, perhaps misspelled or defined by a module not included in the server configuration
Jul 28 21:36:41 fqdn.mydomainname.com systemd[1]: httpd.service: Main process exited, code=exited, status=1/FAILURE
Jul 28 21:36:41 fqdn.mydomainname.com systemd[1]: httpd.service: Failed with result ‘exit-code’.
Jul 28 21:36:41 fqdn.mydomainname.com systemd[1]: Failed to start The Apache HTTP Server.

I removed ‘php_admin_value’ from line 394 and ‘php_value’ from line 415 of /etc/httpd/conf/httpd.conf and now httpd is running ok.

I was going to just re-install Virtualmin fresh. But there may be a time when I will need to rely on this feature so I figure I’d follow all of these bugs through. I’m uncertain why I had to disable those php values or if they may create any issues down the line. From what I understand currently, they are related to mod_php.

I edited this a couple times to be as clear as possible. Any ideas @Joe? Thanks.

mod_php is gone (that’s good, mod_php is terrible), the httpd.conf had directives only available when mod_php is enabled (that’s bad, but you fixed it).

Oh I understand. Centos 7.6, the system the backup came from, had mod_php enabled and Centos 8.2, by default, has it removed. I gotcha.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.