Why is installing virtualmin on aws so different?

SYSTEM INFORMATION
OS type and version Ubuntu 20.04 LTS
Webmin version latest from scripts
Virtualmin version latest from scripts
Related packages php 7.4

I installed virtualmin easily with OVH but when I tried with an ec2 instance the install is very different. It requires a different level of SSL, some items don’t get access to the database, and I can’t access the server with a domain name (only with IP). I think it may have something to do with internal and external IPs that AWS has? I tried AWS Lightsail and had the same issues. I am curious if this is typical or if most virtualmin users are on DO, Linode, Vulture, etc because the install is easier?

AWS has a firewall outside of the virtual machine that you must configure. Also, AWS EC2 requires you setup the IP and available ports. Lightsail should be easier, but it’s been a while.

It is definitely harder to run a standard LAMP server configuration on AWS than some of the more traditional VM providers. You also won’t have the ability to send mail directly. You’ll need to use a relay service.

1 Like

So I tried it multiple times again and the main issue is that I always get an SSL error when accessing with the domain name.

I’ve tried:
changing ssl=1 to ssl=0 in /etc/webmin/miniserv.conf

/etc/webmin/virtual-server/config and change the line ip6enabled=1 to ip6enabled=0

but I still get errors such as CDbConnection failed to open the DB connection or err_ssl_protocol and such. I can get access with ip:10000, but then I run into issues later down the line with the app install, typically with the same error as above.

Is there anything else I may be able to try?