Why can't I get other domains to point to my main site?


First off Webmin/Virtualmin is excellent, thank you to the developers for this wonderful application.

Everything is well except I’m having a very difficult time with multiple domains pointing to one domain.

I’m not sure what I am doing wrong.

I created a virtual server for DOMAIN.COM. I went to BIND and added ‘A’ records for NS1.DOMAIN.COM AND NS2.DOMAIN.COM as well as NS records. I then registered the name servers and IP’s with my registrar and added the NS1/2.DOMAIN.COM name server to the DOMAIN.COM domain.

DOMAIN.COM is working fine.

I want to point other domains to that site. So I added NS1/2.DOMAIN.COM to the other domains with my registrar.

Then i went to the zone for DOMAIN.COM in BIND and added ‘A’ records for other domains that I want to point to DOMAIN.COM. I also added the server aliases for Apache.

But the other domain names are not reachable for some reason (pinging fails). I restarted the server, I waited 48 hours, still not working.

I’m really not sure why this is happening.

Can someone kindly advise?

Thank you!

Woops, very sorry for the multiple posts. An internal server error happened and I hit reload seems it posted three times. Can’'t find a way to delete :frowning:

you can create an alias domain on the main domain to get what you are after.

I created the alias domains in Apache’s configuration as mentioned above, but issue is that the other domains are not even reachable. Ping fails, and reverse lookup fails. I think issue has to do something with BIND.

yes that is why you should create a virtual server as an alias instead of doing it manually.
Virtualmin will make all the correct settings for you (normally)
You can also try this tool to check what the domain is doing and where it is pointed to:

Ah, found what you are referring to. Didn’t know that Virtualmin had that - neat.

Worked perfectly.

Thanks, Roland!