whois Failing

I recently purchased a small VPS, one running on OpenVZ, and for the first time, it is a server that comes with an IPv6 address. Installing Virtualmin, as usual, made setting up this server very easy and everything seems to be running well until I tried to run a whois query recently.

# whois virtualmin.com [Querying whois.verisign-grs.com] [Unable to connect to remote host] # whois 108.60.199.107 [Querying whois.arin.net] [Unable to connect to remote host] ...

What I have tried: Disabled firewall; no difference.

From what I have read on the Internet so far, it appears that I may have not configured the IPv6 correctly (and whois/jwhois is trying to connect on IPv6 and failing).

How do I diagnose what is causing this whois command to fail like this?

About the server:
VPS
OpenVZ
CentOS 6 32bit

Howdy,

Well, it is possible it’s related to ipv6, and you could always try disabling ipv6 if you aren’t using it, as a test.

However, it could also be firewall related. What is the output of this command:

iptables -L -n

I got the VPS for this reason, to learn about setting up a server with IPv6. So disabling IPv6 is probably not the solution I am looking for.

But just in case some one else reading this thread in the future might be looking for that solution, it may be a good idea to share the steps to disable IPv6, if one is not using it.

As per your request, here is the output of the command iptables -L -n

Chain INPUT (policy ACCEPT) target prot opt source destination fail2ban-SSH tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:22 ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:20 ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:21 ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:53 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:20000 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:10000 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:443 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:80 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:993 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:143 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:995 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:110 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:20 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:21 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:53 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:587 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:25 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:22

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Chain fail2ban-SSH (1 references)
target prot opt source destination
RETURN all – 0.0.0.0/0 0.0.0.0/0

I apologise, I misunderstood your instructions. Yes, I should disable IPv6 just to test if it the cause of the problem. How do I disable IPv6 with Webmin/Virtualmin?

Hi,

To disabled ipv6 go to:

Webmin > Networking > Network Configuration > Network Interfaces

Click on the appropriate network interface from the list (usually in the form of “eth0”), disable ipv6 then click “Save and Apply”.

Best Regards, Peter Knowles TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com

Thank you, Peter.

I disabled IPv6 and ran the whois commands again.

I can now confirm that on this server, enabling IPv6 causes the whois/jwhois program to fail. When I disable IPv6, the command works flawlessly.

Now, what can I do to have the whois/jwhois program work WITH IPv6 enabled?