Where are the system stats history on the Dashboard? (Webmin ver 1.993)

OS type and version Debian 11 / CentOS 7
Webmin version 1.993

I just noticed that upgrading Webmin to the latest version 1.993 removes the system stats history (CPU load, Network I/O, Disk I/O, etc).
Was this option removed in the latest upgrade?


After upgrading:

1 Like

I noticed they just went to 1.994 about an hour ago. Maybe its bug.


Nope. It looks the same still in ver 1.994

Ok, I thought they fixed it.


AFAIK Jamie and Ilia are/were not aware of this issue. I think I’ve seen it mentioned before…like a month or two ago, before 1.991. Probably worth a search of the forum for previous discussions.

No, it must be fixed! Try manually restarting Webmin forcefully:


Yep same here. I lost that feature (and the authentic theme configuration page as well) after upgrading to 1.994 a few minutes ago!
I tried


but the real-time monitoring is nowhere to be found!

Operating system Ubuntu Linux 20.04.4
Webmin version 1.994
Virtualmin version 7.1-1
Authentic theme version 19.93.1

Hi Joe… I searched in the forum before posting here, I did not find an earlier post about this.

Thank you, Ilia.
As sidou said, refreshing, restarting the OS, and restarting Webmin by force did not fix it.

Tested on ver 1.993 and 1.994

1 Like

That’s unexpected. What user do you use to login? Is this a root user or root capable user?

I login as a user with sudo.
This user is already added to Webmin’s Users. Has a webmin password, but no password in the shadow file.

I’ll test with root.

I confirm the stats show up as root.

@Jamie, shouldn’t a new webmin_user_is_admin consider sudo capable users too?

There’s also this minor issue of the right-side panel not affecting the layout of the middle (main) content section when the user is not root.
I don’t know if it is related or a separate bug.

Edit: The panel is configured to be open/pinned by default.

This should be a separate topic. Don’t change subjects please.

Actually, this refers not to sudo capable user but to privileged Webin user (which doesn’t have Unix user at all).

Check this patch from this PR. (link was deducted)

1 Like

Thank you, @Ilia. I tried the code in the pull request, and it seems to fix the issue. Now the stats history and its theme options page show up as expected.

Also the side panel thing is fixed as well :wink:

It would “fix” an issue but the patch technically is not correct. We are working on a new one.

1 Like

Oups! I also just applied this patch and it worked for me as well (I use a sudo user with root privileges).
We’ll wait for the final fix.
Thanks for everything :slight_smile: