What's the command in terminal to see the login IP and port info for Virtualmin on Ubuntu 20.04?

ifconfig / ‘ip addr show’ usually do the trick.
Or set it static, so you’ll remember it.

that address was not accessible.

OK, that’s a new one.

But, you can use standard system tools to find out the IP of your system (ip ad sh)…but in many hosting provider environments, the IP of the VM is not the public IP and you’d need to check with your host for what the public IP is. But, how are you even logging in on the command line if you don’t know the IP or hostname?

Understood. Using hostname.domain:10000 worked. but still a command to see the last bit of information after installation would be very helpful.

It’s listed in the Virtualmin install log (/whatever/dir/virtualmin-install.log)

Ahh okay. Would be nice to have a menu to pull that. Like 1. See login info and IP
2. Restart panel etc

First off, if you didn’t reserve your server’s IP so that it’s static you’re going to live in a world of perpetual issues.

Secondly, it tells you where you can access it. If you don’t know your own network so you can access it, you’re going to have a lot of problems.

If I were you, I would stop. Right now. I mean halt everything.

Reserve your servers IP. Make a map of your network on paper. Then get started in earnest. If you don’t, you’ll have nothing but problems.

I DHCP’ed it via my router. BUt when I logged into the panel it change the IP addres from 10.10… to my DHCP’ed local IP. Does that make sense? The IP Is a virtual local IP in the VM. It really did cause an issue on this end.

In other words I was not able to connect via the IP it suggested. I guess that IP address was the correct VIRTUAL IP but it did not work. So I restarted the server. Lost all of that info, so all Im saying is a way to reaccess that information via command after a restart would be wonderful.

Virtualmin does not automatically change your system IP address. Webmin has a networking module that allows you to configure networking stuff, but it doesn’t happen automatically.

You shouldn’t need to restart the panel. It starts automatically on boot, and whenever changes are made that necessitate a restart, it restarts itself.

But, there is, of course, a system standard method of restarting services, which is also how you restart Webmin (the service that hosts Virtualmin):

systemctl restart webmin

Nearly everything in Virtualmin you might need to do from the command line is available via the virtualmin command (but finding the IP and restarting the service are not things you’d normally need to do in Virtualmin, and can be done with standard system tools).

virtualmin help

Will list all of the commands with a brief summary of what they do. And, virtualmin command without arguments will show the usage info for the command. virtualmin help command will show the manpage for the command.

Understood. Well thanks for the help!

1 Like

Your router is where you set the reserved IP for the server. You simply log in to the router, go to the advance settings and look for the networking tab. In that menu you should see the ability to reserve an IP. It will have all the devices on your network listed.

Simply assign the server to whatever IP it is presently on and save it and the router will save that IP for that particular computer so that any time it restarts it lands on that same IP and no other device will be allowed to occupy that IP.

Think there are multiple issues here. It’s a VM with virtual IP, which means host must/should have static internal IP, bridged network/ static route and dns forwarded to VM. I read that host.domain:10000 could reach panel so above must be working. It’s the virtual ip that is jumping and needs to be set static and not dhcp. With the ports enabled and firewall checked, public ip should be reached.

The IP address has stayed the same for the entire logon though. Im on with Microsoft support right now, I have disabled the router fire wall the windows fire walls, I have port forwarded 80 10000 and tons of other ports. I have contacted my router tech support and tried to create an 80 tunnel on port 79. I have dmzed the server. I have bridged the connect in VM so I am super at a loss. I have no idea what else I can do.
My ISP is not blocking any ports. So I have done it all. Theres something blocking these ports. I even forwarded the ports in the ubuntu guest machine.

connecting to the link on my cell phone (MOBILE data not LOCAL) it says the same thing when trying to access the public link. ERR_CONNECTION_REFUSED

What router do you have? How did you put the server in dmz.


This is a new problem. What your router and hosting providers do and how to configure them are unrelated to the subject in your title. Please open a new topic.

Can you move these chats to my other thread?

I don’t think so (it isn’t immediately obvious how, if it can be done). But, I can lock this thread so no more cross-talk happens.