What happened with Virtualmin on ubuntu yestarday

OS type and version Ubuntu Linux 20.04.4
Webmin version 1.984
Virtualmin version 6.17-3
Related packages SUGGESTED

After yesterday’s official package updates, I can’t start Apache Webserver, MySql server, ProFTPD Server, and Dovecot IMAP/POP3 Server.

We did not roll any updates yesterday, or any time in the past few weeks.

1 Like

There were updates to Ubuntu system files yesterday… Maybe thats what he’s referring to…

Yes. Package updates.

Seems strange that all of those services would not start after just a simple update.
Did you reboot?
And if so, do share some logs showing actual errors…

1 Like

Thank you all for willing to help.
Anyhow, I am going to destroy the server. With all tried solutions, I am further of the repair.
Just, in the future, I would like to know if I can believe in Virtualmin Dashboard offerings for Package updates?

It’s your decision about when exactly it is the right time for you to give up and abandon a server instead of continuing to troubleshoot. I don’t see any helper in the community telling you that the server cannot be revived.

Joe was clear in his statement that Virtualmin has not been updated during the past few days and if you still wish to suspect Virtualmin for your troubles then you would be alone amongst all the others who use it concurrently with you and have no trouble with Virtualmin which is identical to your own.

If you do start from scratch, choose a version of Debian or even CentOs rather than Ubuntu 20 LTS if you want less frequent updates and therefore less chances of this sort of thing happening again, with any web hosting control panel you choose to use. Nightly snapshots are mandatory for mission-critical systems and are now so cheap.

Good luck!

1 Like

I got the same updates. Nothing at all happened. In fact, I let Virtualmin update everything - Virtualmin itself, Ubuntu, Plex Media Server, Docker, all of it.

I’ve never had a problem.

1 Like

Virtualmin does not update your system. It offers to use your system package manager to update your system for you. When you choose to update, it runs apt-get to install the available packages, just as you would if you were updating from the command line.

You must regularly update any system that is accessible on the internet. It is not optional.

Since you’ve provided no information about what problem you had, what errors you saw, or what troubleshooting you did, we cannot help you solve the problem. If you want help, please ask good questions and provide the necessary details for us to help you solve it.

1 Like

There’s nothing wrong with Ubuntu. It has a longer lifecycle than Debian, which probably makes it better for less technical users. (Though CentOS/Alma/Rocky lifecycle is even longer, which makes it better still.)

Exactly. And I just click OK every time just like he apparently does. Point being, I’ve never had an issue with it and it updates a lot more than just my OS, so I have no idea why he did.

Thank you all!
I am using Virtualmin for a month or so and started to like it a lot.
The scenario was the next: After the package update, the early mentioned servers stopped working. It was not possible to start them. Tried with all restarts, power-offs, etc.
It was a live production server with many servers/websites, so I had to react promptly. I picked some bad suggestions about reinstalling Apache etc… before came here for help. Usualy it works, but this time was one line too many.
I’ll start fresh server and will use better Webmin file system backup rutine.
And one tricky question - what version of CentOS now?

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.