Website redirect not working (SOLVED)

I am struggling with redirecting my website.

I went under “Server Configuration/Website Redirects” but nothing I try works.

I am trying to forward to where I’ve installed the website.

If I choose source url as “/” and destination "/home

when I try to browse to I get…


You don’t have permission to access / on this server.

then if I browse to I get

Not Found

The requested URL /home was not found on this server.

If I enable “Yes” to Include sub-paths in redirect? Then I get…

The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.

The above message happens even if I say no and point / to


I even tried adding a Cname pointer to my registrars DNS to point to but then I get…

Not Found

The requested URL /index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/ was not found on this server.

What am I doing wrong?

I really need some help on this one.

I usually create several different folders for testing and trying new projects out. So instead of using my TLD folder as the default website location i would use /home for example or /main, etc.

Here’s my problem, my current domain is but my default website is located at , in cpanel I was easily able to redirect or mask to, but I can’t figure out how to do it in virtualmin. I tried the website redirect option but it doesn’t work. I also tried to do this on my domain Registrar’s DNS but can’t seem to do it with a Cname entry.

Why is it that when I create a cname entry on my registrar’s DNS to point domain.tld to domain.tld/home I get this message on the website…

Not Found

The requested URL /index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/ was not found on this server.

If I set the Website redirect in Virtualmin as source URL path of http://domain.tld to Directory on this system of /home then it automatically changes the source to / and then I get this message instead…


You don’t have permission to access / on this server.

When I go to the Preview web site with the internal address or even the external address the parked site works fine but if I use the domain.tld then it gives the error…

Not Found

The requested URL /index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/index.html/ was not found on this server.

It’s been difficult to tell if the reasons were system settings related or DNS related. I suspect most likely it was because of my registrars slow “real” DNS record updating. I discovered that most changes took up to an hour to kick in. I guess this is why running your own DNS servers is more advantageous.

Things are starting to look much better now.

One tip I have for others having issues like this is to check 4 things when testing from the web browser, Internal IP address, External IP address, external Host name, and Firewall ports.

It may work if you test with the external IP instead of the host name, and if it does but not with the host name then its a problem with the DNS.

Well its redirecting fine now, and my alias domain is pointing to it correctly(even masking the real path, Nice!) , but now my Joomla is confused. Lost some path pointers for some files on the page it seems. I think I need to fix this in the joomla config files.

Should they be pointing to the faked path instead?

The fake path becomes the real path. I had to remove the “home” from http://domain.tld/home in the Joomla and VirtueMart components…I will probably find more later.

Nothing like learning the hard way :slight_smile:

Since the redirect, now the script destinations won’t work…


Everything else seems ok…so far


I gave up and just moved the site to the root public_html of the domain. Its just far too complicated to deal with the break / fix issues caused by changing the folder path…I’ll figure something else out for testing folders

To redirect to

  1. Using Virtualmin select appropriate Virtual Server from dropdown menu. Which is located on the left side column.
  2. Navigate to "Server Configuration" -> "Website Redirects"
  3. Click on "Add a new website redirect" button
    • "Source URL path": /
    • "Destination"
      • "URL at other website":

It's the same configuration to redirect to any other website URL

If above returns an error message "Failed to save redirect : Missing or invalid source URL path". Double check that the "Source URL path" read / Nothing else. This field sets the URL that will be redirected, which is always a path in the selected virtual server. / means redirect

If no error message is return but the redirection is not working. Clear your browser cache. The browser is maybe showing you an old cached version. If not working try with another browser.