Website Proxy Settings: sometimes does not create ProxyPass directives

I’ve got a few sites using the “Website Proxy Settings” feature that creates a set of Proxy settings in the apache domain config file:

ProxyPass /
ProxyPassReverse /
<Proxy *>
allow from all

But I’ve got a virtual host that no matter what, it will not update the /etc/apache2/sites-available/.conf file to add these lines. The Virtualmin gui shows that it’s set up, it’s just missing from the config. How do I track down where the error in updating this file is?

Also, watching the /etc/apache2/sites-available/.conf, turning this feature on or off does not touch this file’s timestamp either.



It occurred to me that it could be because mod_proxy or the like isn’t on, so I confirmed. mod_proxy in apache is enabled. Anyone with any ideas?

I just stumbled upon this problem as well. It has to be from one of the new updates. I was able to make reverse proxy sites before (Atleast a month or two ago). Now it doesn’t add those config lines. It does save the link under the proxy website option and say applying but when I look in the config it is missing all of the lines and I manually add them.

ProxyPass / http://site/

ProxyPassReverse / http://site/
Proxy *>
allow from all

I’ve still got the same problem going on. Just to add some details:

Operating system Ubuntu Linux 10.04.3
Webmin version 1.570
Virtualmin version 3.89.gpl GPL

any ideas out there?