Website FTP user doesnt behave as a website FTP user

Mail and FTP Users > “Add a website FTP access user” and I am supposed to create an user that has access only to public_html folder. But that is NOT what is happening. Why?

Users and Groups shows “dev.bfw 500 bfw Developer /home/bfw/public_html /bin/false”

while an FTP session shows:


Connected to

220 FTP Server ready.

User ( dev.bfw

331 Password required for dev.bfw


230 User dev.bfw logged in

ftp> ls -a

200 PORT command successful

150 Opening ASCII mode data connection for file list



226 Transfer complete`

The “users and groups” entry shows the home directory for the user, which is not an access restriction itself. The /bin/false means that they cannot log in via SSH.

If they only see a “.usermin” when logging in via FTP, you possibly have an FTP access restriction in place locking all users into their home directory. Check Limits and Validation -> FTP Directory Restrictions.

i get “FTP directory restrictions can only be configured when the ProFTPd server is installed and in use” ??

i am obviously using it and validation shows proFTPd is ok… puzzled.


Can you call up the ProFTPD config directly in Webmin’s ProFTPD module? If not, maybe some option is configured incorrectly making Vmin think that ProFTPD isn’t installed. If yes, you can also check the FTP restrictions there, under Files and directories.

i was able to bring up proftpd.conf, but i did not find a section called “Files and directories”…

It’s an icon under “global configuration”, on the main screen of the ProFTPD module.

found it, thanks. but it doesnt look like there is anything wrong there…

Looks correct, indeed. Maybe you indeed are using another FTP server besides ProFTPD. The greeting line of your server looks suspicious. ProFTPD greets you with this:

220 ProFTPD 1.3.2c Server (Debian) [ip-address]

But yours said

220 FTP Server ready.

It might be a version/implementation thing, but I kinda doubt it. You might want to check what application is listening on your port 21:

netstat -tlpn | grep :21

“tcp 0 0 :::21 :::* LISTEN 2702/proftpd: (acce”

proftpd -v = ProFTPD Version 1.3.3c


Okay, it is ProFTPD then. My version is 1.3.2c, but I don’t think they changed the greeting line from one version to the next. Might be a configuration thing whether it shows the line like mine does (it might be a bit of a security consideration not to reveal the software in use).

When you log in to the FTP, can you cd out of the directory you start in? Try it preferably with a graphical FTP client.

problem corrected itself… weird! thank you locutus!