webmin-virtual-server (3.88.gpl) Upgrade Never Completes on Ubuntu 10.04

Hi all. Virtualmin has been running great for me until I tried to upgrade it yesterday from 3.87 using apt. Its still running ok as far as I can tell but the upgrade will not complete.

I have cancelled a few times and after running ‘sudo dpkg --configure -a’ then cancelling again (as it just hung again) I can run apt a get as far as below then it doesnt do anything else.

root@server:~# apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 6 not fully installed or removed. After this operation, 0B of additional disk space will be used. Do you want to continue [Y/n]? Y Setting up webmin-virtual-server (3.88.gpl) ...

I can see in the system information that it seems to have been at least partially upgraded as I see ‘Virtualmin version 3.88.gpl GPL’.

When I look in the running processes I see:

12386 root 17:11 apt-get upgrade 12392 root 17:11 /usr/bin/dpkg --status-fd 26 --configure webmin-virtual-server webmin-virtualmin ... 12393 root 17:11 /bin/sh /var/lib/dpkg/info/webmin-virtual-server.postinst configure 3.87.gpl 12408 root 17:11 /usr/bin/perl /usr/share/webmin/run-postinstalls.pl virtual-server 12568 root 17:12 sh -c service lookup\-domain stop 2>&1 </dev/null 12569 root 17:12 stop lookup-domain

It always seems to have hung at stop or start lookup-domain whatever that is doing.

All seems to still be working which is good, but this will stop any further updates working with apt so I am keen to get it resolved. Can anybody help?


Ok so I spent half a day Googling and didnt come up with much. Best I could try was to remove the webmin-virtual-server section from /var/lib/dpkg/status file so it would reinstall it again using apt-get -f install.

Did this but again its hanging on ‘Setting up webmin-virtual-server (3.88.gpl) …’ and the last process seems to be ‘stop lookup-domain’.

Should I file this as a bug?

I got the same problem, i search to solve it, but in vain. Hope someone could help us as soon as possible.

Is your install totally standard? Mines was base Ubuntu with SSH then just ran the setup script, although I disabled the following services after installation using the commands below as I wasnt using them:

rm /etc/rc*/*clam* rm /etc/rc*/*spam* rm /etc/rc*/*proftpd* rm /etc/rc*/*postgres* rm /etc/rc*/*dovecot*
Maybe this has caused the issue…?
*edit - Replace em> with asterix

Also, added the following extra packages

apt-get install php5-curl php5-gd php5-imagick php-apc imagemagick unattended-upgrades apticron libapache-mod-security

Thanks to andreychek and Jamie this issue is now solved.

The fix is to kill the ‘stop lookup-domain’ process and in my case I also had to kill a ‘start lookup-domain’ process after that as it was still hanging.

Seemingly this is caused by a problem with the Ubuntu upstart system.

Thanks +premierhw, that did it for me.

Find the pid:
root: /var/log# ps -ef | grep lookup-domain

root 12947 12946 0 15:31 ? 00:00:00 stop lookup-domain

find the pid (in this example, 12947), and

kill -9 12947

then do the same but look for the pid of “start lookup-domain”

solved it for me, too

Glad it solved it for you as well. I had the same issue again with the latest Webmin update but the above fix again worked.

Registered just to say thanks so much for getting me out of neverending dpkg hell. Deleting the lookup-domain processes worked for me.