Webmin User cannot Log in

I have created a second webmin user "testuser", but when I try to log in with that user I keep getting "Login Failed".

And the only error message I seem to be able to find is "Non-existent login as testuser…"

Operating system Redhat Linux Fedora 5
Webmin version 1.340

Installation via rpm.

I have read the documentation and followed it, it seems to be pretty straight forward, yet it is not working for me. I have also tried unix user, set to password and installing auth-pam. At the moment I would be just happy if I could get a webmin user working. Usermin appears to work. and the root login works fine. also if logged in as root and then impersonate that user it appears to work. All the other modules look like the work.

Any ideas on what I could try next?

Many thanks.

Hey Roy,

Are you sure you’re actually creating a Webmin user? It sounds like you’ve created a system user–which is not automatically a Webmin user (though it is automatically a Usermin user), even if you’ve set Webmin to use the system user database for authentication via PAM or shadow.

The “Users and Groups” module creates system users, which don’t automatically have Webmin access. The Webmin Users module creates Webmin users (which may or may not be the same as system users). Confused yet? :wink:

Thanks for you reply Joe.

I have setup a user "testuser" in "Webmin" -> "Webmin Users" I have manually set the password to "testuser", so it should not be using "Unix authentication", but I still can not log onto the webmin interface with this user?

Webmin still denies the user exists, even though it is stored in the mniserv.users and in the webmin.acl file.
The Pam settings for webmin were set up by the rpm, at least I assume so ;-), they are set to pam_unix.so for "Authentication" could that be interfering?

Many thanks.

Hey Roy,

I dunno what to make of that. Webmin should allow PAM or shadow passwords to co-exist peacefully with “Webmin-only” users, and I’ve just recently created such a user for our slave DNS server, and it worked fine.

Is there any chance there is another Webmin installed on the box that might be interfering with configuration and users? (I’m flying blind here…that doesn’t seem like it could actually cause this problem, but I’m at a loss for what could.)

You might try creating a matching system user, just to see if it is, in fact, something to do with the PAM and/or shadow stuff causing things to fail.