Webmin "Upgrade Webmin Now" Button non-existent in most themes


I have been having a bear of a time updating my Webmin. I’m running Virtualmin/Webmin on a production server and three or four development servers (all running CentOS 5.4 i386 r x86_64), and none of them were running the latest version of Webmin.

I checked around Webmin, and couldn’t find how to update anywhere - the Virtualmin stuff doesn’t include Webmin updates, (I didn’t look very hard) but a “yum update webmin” didn’t work either (if memory serves it is wbm-xxxsomething). Google searches simply said:

Webmin -> Webmin Configuration -> “Click the ‘Upgrade Webmin Now’ Button”

However, none of my Webmin Configuration screens had an update webmin button. Ultimately, the problem was that of all of the themes I have installed (Old Webmin, Blue Framed, Caldera, MSC.Linux Virtualmin Framed, Virtualmin Mobile), MSC.Linux is the only one that shows the “Update/Upgrade Webmin Button” - and even then I have to muck around with it before that appears. I have to change the them to MSC.Linux, then go to Webmin -> Webmin Configuration, (still no update button here, so) then “Return to Index”, before finally being able to click on the “Upgrade Webmin Now” button. The other themes don’t seem to have this “Return to Index” button - and if they do, it actually returns to the Webmin Configuration page instead of this elusive “Index” with the upgrade button.

Seems quite complex and unwieldy…is this a bug, or is there something funky going on with my installations (I used the install.sh to install), or are all of these other Themes just written poorly…though some of them at least give the illusion of propriety…like the “Virtualmin Framed Theme”. One would expect to be able to upgrade Webmin while using that theme, at least…however no love.

Anyway, sorry for being long winded and the rant, but it may help someone else hunting for how to upgrade Webmin.

  • Acorp



How did you go about installing Webmin/Virtualmin?

If you used the install.sh script, you should have rpm packages installed, that should be upgradeable via yum, or from the system information screen in Virtualmin.


Hi Eric,

I’m sure it got lost in the verbosity of my first post, but I did use the install.sh script for all of my installs.

I looked on the “System Information” screen - seemed like the logical place. However, my system(s) report:

“Webmin version 1.500”
“Package updates All Virtualmin packages are up to date.”

For posterity’s sake, the current version of Webmin as of 4/15/2010 is 1.510, so Virtualmin is lying when it says all packages are up to date.

I’m sure with a bare minimum of effort I could have done a command line yum upgrade, I’m just thinking that eventually (and maybe even currently) some of the target market for Webmin/Virtualmin might not be comfortable going to the command line, and a Webmin update seems like something that should be easy to accomplish from within the GUI.

Again let me point out that I am no longer in need of a solution, just looking to know if this is a “bug” that should be reported for correction in future versions of Webmin/Virtualmin, or if it is just me and my servers.


  • Acorp


Hmm, this is interesting…

If I click on the “Virtualmin Packages” hotlink in the “All Virtualmin Packages are up to date” text on the System Information screen, I see a whole list of packages most/all of which are up to date. However, at the bottom of this list I see:

webmin A web-based administration interface for Unix systems. Running latest 1.500-2 installed

So, it thinks that 1.500-2 is the latest, even though the “Update Webmin Now” button (when I can find it) says that the latest is 1.510.


  • Acorp



I’m sure it got lost in the verbosity of my first post, but I did use the install.sh script for all of my installs.

My apologies, I see it now :slight_smile:

For better or worse, the Virtualmin Framed theme is really the only one that has full functionality in Virtualmin.

In this case – Webmin version 1.510 isn’t actually available yet in the Virtualmin repository. It is, however, available on the webmin.com site as a wbm module, and it’s in the process of being made available for Virtualmin.

I have a feeling that what you’re seeing is some themes not understanding how to do an upgrade via yum against the Virtualmin software repository.

If you’re using Webmin 1.500, and Virtualmin 1.377, you’re using the latest software versions available in the Virtualmin repo.


OK - that would make sense. I thought one of my servers was running 1.480, and I still wasn’t prompted for an update, but not positive about that. I think I’ll hold off on updating this last server until 1.510 is in the Virtualmin repository, then see if it automatically suggests an upgrade.

And actually, the theme I use predominately is the Virtualmin Framed theme, anyway, so nothing much lost there. I used to like the Stressfree/Tiger theme (from a third party) but the sidebar (server information) stopped working somewhere along the way so I moved back to Virtualmin Framed.

Any idea when 1.510 will be in the Virtualmin repository?


  • Acorp


Any idea when 1.510 will be in the Virtualmin repository?

I’m not sure, but hopefully soon :slight_smile:


I don’t know if this should be here or not. But I was running a newer version than what is in this article and it’s still a problem, the only theme that shows the upgrade webmin now button is the MSC Linux theme.

Hi, I’m having the same problem…

Webmin version 1.585
Virtualmin version 3.92.gpl GPL
Operating system CentOS Linux 6.2

Standard Webmin modules
Warning - you are not running the latest Webmin version 1.590, so these modules will probably fail to install.

Failed to install standard module : Module “” requires Webmin version 1.590 or above

So, what to do? Wait for the update to be available under Virtualmin repos?


Webmin 1.590 is, as of today, still not available in the Virtualmin repo but it HAS been released as a stable version.

Since the “virtualmin framed theme*” does NOT show the “webmin configuration > upgrade webmin” button, to upgrade webmin now (before it is added to the virtualmin repo) search for “upgrade webmin” and click on “upgrade webmin” in the result list. The button does not show up, but the functionality is there.

Since it HAS been released as a stable version I did the upgrade today and things seem to be working fine. I have a bit of a paranoia about outdated software…

*this theme still the only theme fully compatible with all of virtualmin functions, so if your server is a webserver you have no other choice.

Webmin 1.590 should be in all the repo’s now (actually, as of several days ago).

If you aren’t seeing it, let us know what Linux distro you’re using, and whether you’re using the GPL or Pro version of Virtualmin, so we can look into that further.


CentOS 6.3 and GPL. It wasnt there this morning

> yum repolist
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
 * base: mirrors.easynews.com
 * extras: mirrors.xmission.com
 * updates: centos-distro.cavecreek.net
repo id                 repo name                                         status
base                    CentOS-6 - Base                                   6346
extras                  CentOS-6 - Extras                                    4
updates                 CentOS-6 - Updates                                 205
virtualmin              RHEL/CentOS/Scientific 6 - x86_64 - Virtualmin      73
virtualmin-universal    Virtualmin Distribution Neutral Packages           175
repolist: 7348

> yum info webmin
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
 * base: mirrors.easynews.com
 * extras: mirrors.xmission.com
 * updates: centos-distro.cavecreek.net
Installed Packages
Name        : webmin
Arch        : noarch
Version     : 1.590
Release     : 1
Size        : 52 M
Repo        : installed
Summary     : A web-based administration interface for Unix systems.
License     : Freeware