Webmin update to version 1.999 — Error: 500 - Perl execution failed

OS type and version Raspbian 11
Virtualmin version 1.999

I used Webmin for a few years and are very happy with it. Now, I followed the suggestion to update from version 1.979 to version 1.999.

The download completes and the unpackaging started, but it does not come to an end. Some time later, a red error message appeared:

Error: 500 - Perl execution failed – Undefined subroutine &main::setvar called — /stats.cgi?xhr-stats=general`

After rebooting the Raspberry Pi 4, this error page appears, if I try to access Webmin homepage:

Error: 500 - Perl execution failed
Undefined subroutine &main::webmin_user_is_admin called at /usr/share/webmin/authentic-theme/authentic-init.pl line 1768.

What can I do to fix it?

Any help would be greatly appreciated.

This is harmless. Although, you should not see this error either. The solution to this problem is as simple as:

systemctl restart webmin

I have given a try myself upgrading from Webmin 1.979 to 1.999.

Well, in case Webmin was started outside of systemd and preload (caching) is enabled the right fix for your problem would be to SSH to your server and run from the console:


It does come to an end, and upgrades properly. This is just a false-positive error message on the UI. It was fixed with Webmin 1.999.

Sorry. Does not help. Same error on homepage after restart.

I tried it (with sudo). The command was not found.

That means something interrupted upgrade process.

What you can do is to run:

apt-get install --reinstall webmin

If you don’t have Webmin repo setup, you can download Webmin 1.999 with:

wget https://sourceforge.net/projects/webadmin/files/webmin/1.999/webmin_1.999_all.deb

and then run:

apt-get install --reinstall ./webmin_1.999_all.deb

This gives (translated from german):

E: The dpkg process was interrupted; You need to manually run 'sudo dpkg --configure -a' to fix the problem.

Should I do that?

dpkg --configure -a

This did it. Webmin is up again.
Thanks a lot.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.