Webmin update - perl issues

CentOs 8.3
Webmin 1.973

With the last Webmin update, I am now getting under DNS records:

DNS and Sender Policy Framework options
HTTP/1.0 500 Perl execution failed Server: MiniServ/1.973 Date: Fri, 12 Mar 2021 14:59:01 GMT Content-type: text/html; Charset=utf-8 Connection: close

ERROR β€” PERL EXECUTION FAILED

Undefined subroutine &virtual_server::can_domain_dnsssec called at /usr/libexec/webmin/virtual-server/edit_spf.cgi line 60.

The save button doesnt appear and the error is showing for all domains under DNS options. Anybody with similar issues? behaviour same on 2 of my servers after the update so must be related to the recent release.

Yep. Same error.

Webmin > Servers > Virtualmin Virtual Servers > DNS Options

Also noticed that the same IP is listed twice.

Richard

Confirm, same issue on β€œCentos Linux 8” Is there any temporarily workaround or we needed to wait next update?

Same error here.
Miniserv error logs show /virtual-server/edit_spf.cgi : Perl execution failed : Undefined subroutine &virtual_server::can_domain_dnsssec called at /usr/libexec/webmin/virtual-server/edit_spf.cgi line 60.
Webmin 1.973
CentOS Linux 7.9.2009

Same issue here: Undefined subroutine &virtual_server::can_domain_dnsssec called at /usr/libexec/webmin/virtual-server/edit_spf.cgi line 60

Hi,

Thanks for the heads up.

It was a bug in Virtualmin 6.15 which already been fixed.

You can manually edit mentioned on the commit file and restart Webmin manually afterwards.

1 Like

Thank you, it worked :+1:

also thanks for the heads up on that issue, sorted :grinning: