Webmin to Virtualmin?

||===========================================||
| Operating system > Debian Linux 10
| Kernel and CPU > Linux 4.19.0-12-amd64 on x86_64
| Webmin version > 1.970
| Authentic theme version > 19.70
||===========================================||

I’ve posted something on stackoverflow but there isnt answer yet…

I am using the “Filesystem Backup” from Webmin, but this recovering system doesn’t works on my server.

What i did :

  1. Backup creation
  2. Manual modification of a file to create a difference between my backup version and the post-backup version.
  3. Restoring the backup : the action log tells me that the restoration is complete.

But when I go to see my files, nothing has moved.

I don’t know where to go to see if there is any error, I don’t know where it could come from … any idea?

Thank you in advance for your help :heart:.

PS: i think i’m going to pass on Virtualmin, that seems more easy to manage stuff…

Hello @kriffin and welcome to the community.

Hmm. You are manually editing the archive in step 2. If you see no files upon restore, perhaps step 2 does not produce the outcome that you expect it to; the restore overwrites the existing files and you find that ‘nothing has moved’, apparently.

If you share more info and specific commands / operations that you are using then our suggestions can be correspondingly more specific.

More precisely, I am renaming a file with a different name in the FTP.
So the restore should get the file back to the FTP when I do a full archive restore, but it doesn’t.

I tried to restore the file alone and I also tried to restore the entire archive.

The log tells me that the restoration is complete. But nothing has changed.

I’m not doing any commands (unix or otherwise) and I have no way of seeing what the tool is doing, at least to my knowledge.

I am using the webmin interface to do system file backup / restore.

You can see a preview here : https://i.stack.imgur.com/YZqgK.png and https://i.stack.imgur.com/OakoK.png