Webmin Terminal wss connection time out

Using raspberry pi OS
Virtualmin version 2.111

Hi there, I have installed webmin and it is working fine in general. However, when I add servers in the Webmin Server Index with the “login via Webmin with username”, and try to use the terminal from the remote server (by clicking on the icon in the server index) I get the following error:

Error: Connection to the socket wss://X.X.X.X/xterm/ws-555 lost

If I look at the developer console in the browser it says that it has timed out. I have tried this with SSL enabled and without in both the slave and the master, the user I am using to establish the connection is the sudo user that comes with the operating system, so it has access to everything. When login to the terminal locally on the server it works well.

When I look at the /tmp/.webmin/ws-555.out I get the following:
Listening on port 555 and then timeout waiting for connection at …-webmin/xterm/shellserver.pl

I can’t find any other logs related to this, I have checked in miniserv.errors and miniserv.logs.

I am out of options and researching this online has not helped. I would greatly appreciate some help with this, please.

I think you’ll probably need to login to those servers directly to use the terminal. I don’t even know how we’d handle proxying that connection through Webmin.

Hi Joe,

Thank you very much for answering.

Just to clarify so I can stop searching for a solution, this is not intended to work this way right?

It’d be quite handy for my needs, but if it can’t be it can’t be.

Thank you again.

I mean, I’m sure we’d all like it to work. But, I can see how it’d be tricky to make it work. I don’t remember this use case coming up in the development conversations around this feature, so I don’t think @Jamie has done any work to make it work…and I’m not sure how easily it can be made to work. Linking to a Webmin system in the servers index is a very simple CGI proxy, I’m not sure it’s possible to make it proxy WebSockets.

Yeah this would be very tricky to support, as the proxying done in the Webmin Servers Index doesn’t yet support websockets proxying, and it would be fairly tricky to add…

Might be best to just give a clear error, and suggest a direct login.

Yeah, I’ll do that

Thank you for the clarification guys is much appreciated.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.