Webmin reinstall fails

I have been using webmin for many years. I recently installed it on a n new centos 7 box and it was functioning. Following some hard drive corruption and repair I could no longer log in to webmin so I uninstalled it.
When I try and reinstall using yum I get the following error output,

Running transaction
Operating system is CentOS Linux
Undefined subroutine &main::pack_sockaddr_in called at -e line 1.
Port 10000 is already in use
error: %pre(webmin-1.955-1.noarch) scriptlet failed, exit status 2
Error in PREIN scriptlet in rpm package webmin-1.955-1.noarch
Verifying : webmin-1.955-1.noarch
webmin.noarch 0:1.955-1

I have run “netstat -tanpu | grep 10000” and get no output
I get the following out put for cat /etc/services | grep 10000
ndmp 10000/tcp # Network Data Management Protocol
ndmp 10000/udp # Network Data Management Protocol

Any help is appreciated to get Webmin reinstalled, thanks

Webmin is running when you tried to reinstall it. Stop it first.

Webmin is no longer installed on the system it was completely removed.

systemctl start webmin
Failed to start webmin.service: Unit not found.

no output from
rpm -qa | grep webmin

also miniserv is not on the system

Something is on port 10000. So, find out what and kill it.

netstat -tulpn|grep :10000

Er, I guess you said you already did that.

Something was running on port 10000 when you tried to reinstall, even if it isn’t now. So…try it again, I guess?

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.