Webmin Password set for MYSQL

It took me 4 hours to realize that Webmin/Virtualmin has been setting a wrong password for MYSQL user.
What i did/wanted to do was to create a second user for a site, so that would be the user to access sites db.
Everything was okay, i have created it and added the corresponding database to it, but when i tried to connect to DB it said :
Access denied for user ‘myuser’@‘localhost’ (using password: YES)
After trying to change 983475893 permissions and privileges, re-setup the password(from virtualmin panel, from webmin panel) and everything, it didnt work.
Finally i tried to go to MYSQL with the root user and changed the newly created user password to what i have been trying to set for 4 hrs.
And voila, when i set the password from MYSQL directly(using 3rd party app) i managed log in.

So my question is - Are there any password policies for MYSQL password or its a bug that Virtualmin inserts wrong password ?

The password that i tried to set was: M2|2T’*88%wg9y
Maybe the field is being parsed wrong or something like that happens, probably.
I tend to believe that ""character may break it but cant confirm it, haven’t investigated any further.

MySQL used to have a shorter maximum password length than it has now…I think Virtualmin/Webmin might be imposing that old limit. I’m not sure. It probably shouldn’t silently truncate the password, if that’s the case, so it’d still be bug-like if it let you think you were setting a password to something but it wasn’t.

Can you try it with a shorter password, and also one that is long but without special characters? That’d help narrow down what we need to file in a bug for Jamie (it may just need a good error message, or it may be an issue of not properly dealing with special characters, I dunno).