Webmin over Let's Encrypt not working

I had self signed certificate for my Webmin and I now generated Let’s Encrypt Certificate for my main Webmin Server.
In current certificate section, its showing correctly that I have Let’s Encrypt certificate on my server.

**Details of current certificate**
**Domain name** blabla.myserver.com **Additional domains** blabla.myserver.com
--- --- --- ---
**Issuer name** R3 **Issuer organization** Let's Encrypt
**Valid until** Sep 24 10:44:57 2021 GMT

But browsers still showing warnings about self sign certificate. Why is this happening?

Are you talking about your Webmin Hostname or a website?

The Main Webmin hostname. My main server. Not any domains/users. They(client domains) are working fine. But I want Let’s Encrypt in my Webmin Admin. Browsers should accept the certificate but its accepting self signed.
What is the problem?

I haven’t done that in a while, but try this: Please go to Webmin/Webmin Configuration/SSL Settings, and see if SSL support is enabled.

I’m sorry, try Webmin Configuration…

Yes it enabled.

Try clearing Cache and try another browser. try starting your domain with https://…

Tried. no success. Even tried on mobile browsers.
Did I missed something ?

Try getting another cert

Select the virtual server for Webmin in the Virtualmin tab, go to Server Configuration > SSL Certificate and select the Service Certificates tab.

Do you have “Webmin domain certificate enabled?” set to Yes? Also, I think there’s a “Copy to Webmin” button if you haven’t done it yet.

Webmin domain certificate enabled? was set to yes by default with others.
I have done copy to webmin and copy to usermin many times… i reappears after some time again.