Webmin on Rocky 9.1


I installed Webmin 2.0.13 on Rocky 9.1 (kernel 5.14.0-162.12.1.el9_1.0.2.x86_64) and I could not change the default root password until I installed
dnf install perl-File-Basename

My questions are:

  1. Is webmin supported/tested on Rocky 9.1?
  2. Installation instructions are provided for CentOS/RedHat/Fedora and CentOS stream, therefore I used the instructions for CentOS/RedHat; should I been used the CentOS stream instructions instead?



How are you trying to change root password? I have a test rocky9 snapshot I can boot up.

I changed with
webmin passwd root
[root@machine1~]# webmin passwd root
Can’t locate File/Basename.pm in @INC (you may need to install the File::Basename module) (@INC contains: /usr/local/lib64/perl5/5.32 /usr/local/share/perl5/5.32 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at /usr/bin/webmin line 13.
BEGIN failed–compilation aborted at /usr/bin/webmin line 13.

That was the error before I installed perl-File-Basename, after it worked correctly so far… but I am wondering if Rocky 9.x is supported/tested in any ways.

right, I’ll test tomorrow.
What about here same issue? Rocky9 I think is a A grade OS.

Sorry I installed Virtualmin, was this just a webmin install?

Yes, only webmin.

Sorry not sure about webmin, maybe @Jamie can help.

I just tried to install Webmin on a clean RHEL9.1, but the repo setup failed so I had to download it manually and install.

To answer your question, perl-File-Basename does not exist on a clean RHEL 9.1 after installing Webmin, so I don’t think you need to be concerned about using Rocky 9.1

Hope Rocky will be ok.


You were missing a dependency for one, almost entirely unnecessary, feature (you should not use Webmin passwords, generally speaking, you should use system passwords). That said, there probably are other places File::Basename is needed, so it’s good to install it. But, you do not need to use the webmin passwd command. Webmin defaults to using system users unless and until you tell it to do otherwise by explicitly setting a separate password. I recommend you use passwd (the system command, not the webmin subcommand).

The package doesn’t depend on it because it’s different across various distributions that use RPM (RHEL broke their Perl a few years ago, by breaking out a bunch of core modules into separate packages) and many RPM-based distros do not have this package because they don’t have a broken Perl package.

They’re all the same. All distros with RPM have the same package.

You’re making way too big of a deal out of this. It was a missing dependency for a command you probably shouldn’t even use. (But, it’s also good to install the missing dependency, since the webmin command probably uses it elsewhere, since I wrote it and I use standard modules whenever possible, while Jamie uses his own implementations of most of the core modules.)

Thanks Joe. I am not making a big deal really, I am not a native English speaker and maybe it sounded bad how I asked, but this was not my intention at all, just wanted to know if its supported or not. I am sorry it sounded like that to you.

Thanks for your reply.

1 Like

It’s surprising that File::Basename was missing, as it’s a dependency in the Webmin RPM package…

Maybe because I did not used the full script and I installed from here link ?

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.