Webmin not running on https://

I saw the Intro video and the very first thing I noticed is that webmin should run on https://. My setup does not… I tested running my cp (webmin /virtualmin) but Im getting this error…

Secure Connection Failed

An error occurred during a connection to XXX.XXX.XXX.XXX:10000.
SSL received a record that exceeded the maximum permissible length.
(Error code: ssl_error_rx_record_too_long)

I’m alarmed… How do I setup webmin to run on https:// ?


you can set it in webmin configuration under SSL encryption however you must have the SSLeay Perl module installed<br><br>Post edited by: ronald, at: 2008/07/05 12:24

You haven’t told us your OS/version, or how you installed Webmin and Virtualmin.

If you are using a supported OS, the automated install script insures you get all of the right packages and a known working configuration–very quickly and very easily.

Sweet! Got it working now. I’m running on CentOS 5.2.
Thanks guys…


I am running into the same issue. The platform is solaris 10-x86. The version initially installed, 1.1, worked. I downloaded the 1.4 package, added the module/package from the webmin module option, and began getting this same error noted.

Did a pkgrm of 1.1 and 1.4, pkgadd again of 1.4, and same error.

Secure Connection Failed

An error occurred during a connection to actidb01:10000.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

Any ideas where to look or how to resolve?


Hi Tim,

I’ve usually seen that error when either the SSL certificate, key, or ca directives were pointing to the wrong file.

Can you verify all the SSL related files you have, and verify that where Virtualmin is looking for your cert, key, and ca are all using the correct files?


Where would I look for the SSL related files? On the solaris box or the client machine?

I installed webmin on two diferrent hosts, debian 5.0.1 and solaris 10. The debian host works as advertised. The solaris host worked with 1.1, installed during base installation of solaris. When I went to webmin 1.4 on the solaris host, that is when it stopped working. The debian host is working.

Any more thoughts or direction?


What, what all have you done or attempted to do, SSL-wise?

Had you at some point attempted to install a commercial certificate?

Or is this a default Virtualmin install?

And the problem you’re running into is when you access Webmin?

Nothing has been done at all related to SSL.

Yes, the issue is with webmin. Going to the URL generates the error.


Ahh, interesting. So that certainly isn’t desirable :slight_smile:

If you log in over SSH and type these commands, what output do you get:

  1. grep ssl /etc/webmin/miniserv.conf

  2. grep keyfile= /etc/webmin/miniserv.conf

  3. grep certfile= /etc/webmin/miniserv.conf

  4. grep extracas= /etc/webmin/miniserv.conf

Some of the above may not produce output, that’s okay, just mention when that’s the case :slight_smile:


These errors indicate to me a mismatch in the OpenSSL version and the Perl Net::SSLeay library bindings. I would suggest reinstalling Net::SSLeay, and see if that corrects it (you may have to rebuild from CPAN, if there isn’t an up to date package of Net::SSLeay in whatever pkg repo y ou’re using).

For recent install, a reinstall has fixed this error on a couple of servers for me.


I’ve just hit this issue installing webmin on a new install of centos 5.6
never seen it before

ssl installed:


I installed these via yum

error message:

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

tried reinstalling but still same issue
webmin is running and available via http

any ideas how to fix this please?

oh yea installing webmin via rpm

still cant get webmin to work.
weird. never been known. it always installs first time

found log in miniserv.error about authen::pam errors
so installed authen::pam

still no luck
current miniserv.error…

[29/Jun/2011:20:54:56 +0100] miniserv.pl started
[29/Jun/2011:20:54:56 +0100] PAM authentication enabled
[29/Jun/2011:20:55:03 +0100] [xx.xx.xx.xx] Bad Request

browser still has the same errors
help anyone!

I’m having the same issue. Although, mine broke after an update or addition of the replacement of the self-signed cert with a wildcard cert. CentOS 5.9 x86_64.

I’ve tried https on several different browsers and OS’s all with similar errors.

I’m having a similar issue to those above. I have just built a new server with new updated OS and virtualmin software. I get the same error message as the people got above when I try to connect to the https administration page for the first time.

This is a centOS minimal 7 install with the latest install.sh installer set up. Below is the 4 steps that I took to get here.

  1. install OS
  2. install perl using ‘yum install perl’ over SSH
  3. Install virtualmin using install.sh over SSH using a local FQDN
  4. add FQDN to hosts file in Win7 and try to access ‘FQDN’:10000 using cometbird

I tried some the above grep commands but could not understand the output. I did not include them since I was not sure if they were relevant but can send them if requested. Also, from SSH the virtualmin command is responsive and returns a list of flags.

Thanks for any help you can give.