Webmin login not working

The login screen in my server http://ip:10000 is not working/opening.

I tried using different browsers and ISP, but nothing worked.

Although, SSH is working fine. The websites hosted on the VPS (CentOS) are also working normal.

Can someone let me know how to verify that Webmin is running? Can you provide me the steps?

Also, my VPS providers hasn’t blocked port 10000. I checked with them. Will have to see if any firewall blocked the same. How to check that?


You may want to start by verifying that Webmin is running.

You can do that with this command as root:

/etc/init.d/webmin restart

After doing that, are you then able to access the login screen?


Thanks for your reply.
I tried doing what was written (screenshot attached) but after that as well I am unable to access the login page.

Anything else needs to be checked?

I flushed the firewall rules with
/etc/init.d/iptables restart
and all started working well.

Thanks a lot for the help.

Will report with future problems. :slight_smile:

That’s excellent, I’m glad it’s working for you now!


But why is it not working again? When I run the script, it works… but again after a few seconds I am forced to run the script! What’s wrong?


Are you using some sort of automated firewall tool that’s adding rules on it’s own?

Also, which CentOS version are you using?


When I flush the firewall rules with “/etc/init.d/iptables restart” I can login to webmin but after a few minutes I am again unable to access. I don’t know how my firewall is blocking webmin port 10000.

I am not using any automated firewall. Can someone help me?

Hmm, what is the output of this command:

ps auxwf

The iptables rules shouldn’t ever change on their own… seeing what processes are running may help us identify if perhaps there’s some sort of tool running that’s causing the problems you’re seeing.


While I put the command “/etc/init.d/iptables restart”, I get the following

/etc/init.d/iptables restart
‘ptables v1.4.7: Invalid target name ACCEPT Try iptables -h’ or ‘iptables --help’ for more information.
iptables: Setting chains to policy ACCEPT: nat raw filter m[ OK ]
iptables: Flushing firewall rules: [ OK ]
iptables: Unloading modules: [ OK ]
iptables: No config file. [WARNING]

Anything to do with this “No config file” thing?

Also, I want to ask you, is it safe to paste ps auxwf results here?