Webmin is adding the port after <MY_SITE_URL> but i use proxies

OS type and version Ubuntu Linux 22.04.4
Webmin version Webmin 2.111

i am having some trouble getting this to work as i am very new to webmin. i recently started using reverse proxies with NGINX. the reason for this was so i don’t have to keep adding ports to the end of my URL’s…

unfortunately i cannot figure out how to log in to webmin without it redirecting me to <MY_SITE_URL>:2096.

it will go through port 443 (NGINX) and thanks to NGINX end up at port 2096.

if webmin goes to <MY_SITE_URL>:2096 i get a big warning that my site is not secure… however. if i remove the port from the url bar it tells me it is SSL secured again.

thank you guys in advance!


For internal redirects configuration, check the Webmin ⇾ Webmin Configuration: Web Server Options page.

For proper Webmin and Nginx proxy configuration, check our FAQ:

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.