Webmin - File Manager - default colours

Operating system: CentOS Linux
OS version: 7.9.2009
Webmin version 1.981


Am I the only one finding the new colour scheme for the File Manger difficult to view? Can we go back to the previous colours, or could someone point me in the right direction as to how to amend the css?
Thanks.

You’re the only one using an old theme, I guess. :wink:

This isn’t a new color scheme, nobody meant for it to ever look this way. I don’t know exactly why it looks like that in the old theme, though. I guess some styles got renamed and nobody told the old theme, or something else weird.

@Ilia or @Jamie, do y’all any idea why old theme is doing…whatever this is in File Manager?

Does this also happen in other modules, where the tables with checkboxes exist?

What do you get set in /etc/webmin/gray-theme/config or in /etc/webmin/blue-theme/config files?

Why not using Authentic Theme?

Thanks for the replies.

Yes. Wherever there is a table (eg Edit databases, edit users, install scripts etc) the latter displays

Neither of the folders/files /etc/webmin/gray-theme/config or /etc/webmin/blue-theme/config appear to exist. I have a folder /etc/webmin/authentic-theme/ folder but that’s empty.
I have tried changing to the Authentic Theme, but after system refreshes the page it all looks the same.
I administer 2 separate servers and both show the same views/colours. Appears to have occurred since a recent update to Webmin.

Either you’re switching wrong or your installation is broken.

How did you install? If you used an RPM (or our Virtualmin install script, which uses RPMs packages on CentOS), you can verify the install with rpm -V webmin.

And, to clarify on the “you’re switching wrong” option, there are two places you can change theme. One applies only to the currently logged in user and can override the system preference. Webmin->Change Language and Theme is a user preference. Webmin->Webmin Configuration->Webmin Themes sets the system preference (but will be overridden if you also set the user preference).

:laughing: … interesting …

Do you perhaps have any overlay themes activated?

Actually, I can’t reproduce this issue with old grey theme or Authentic theme. What theme are you using?

It looks like he’s using some sort of colorblind mode.

Thanks Joe, That advice has allowed me to change to the Authentic Theme via

Webmin->Change Language and Theme.

Just to clarify the other queries, installation done over 5 years ago on a clean CentoS server by using the Virtualmin GPL Installer and then

chmod +x install.sh ./install.sh

no issues with display colours over those 5 years, until a few weeks ago. All seems OK now though when using Authentic Theme.

rpm -V webmin

gives no output.

Hello,

If you are using the “vitualmin framed theme” (virtual-server-theme-9.5.wbt.gz) then the file

/etc/webmin/virtual-server-theme/config

should look like this

inframe=1
applet_dark_edge=333366
cs_link=376ebd
cb=class=‘mainbody’
tb=class=‘maintitle’
cs_table=f5f5f5
applet_dark_bg=8888aa
applet_light_edge_hi=D0E0FC
texttitles=1
applet_light_bg=ffffff
noindex=1
applet_body=e8e8ea
applet_light_edge=D0E0F0
applet_dark_edge_hi=333350
functions=theme.pl
applet_text=333333
framed=1
cs_header=D0E0FC

i noticed the update added come colors to some lines.

For other themes i don’t know. You could compare the /etc/webmin/“used-theme-name”/config file with one from a backup.

To beat the question, why i am not using the new theme: i did for a while, but the default color went from a nice dark blue to a very ugly, very bright blue and the dark blue isn’t even in the presets anymore. After having wasted a few hours trying to get the color right again, i switched back and got on with more important things.

hope this helps
Jan