Webmin error 100 while fresh install

I get error 100 while trying to install virtualmin , fresh install. seems get error on webmin cannot be found. seems some changes was made on 23.04.2020 03:45 or something like this,and the auto install script doesent works anymore.

It already tells you the issue, you have some repos multiple times in the sourcelist.
Remove the doubled entries and it should work without issues.

delete from where and what? this should work without edit by me. i dont know what to delete…

I overlooked the part that you got that during the installation from virtualmin itself. Sorry.
I noticed an issue which appeared today with one of the depos. Its possible that more are affected.
I assume it will be fixed today or very shortly.

no problem, i hope they will fix soon.

Glad I found this thread. I’ve been tearing my hair out trying to install a new server and I’ve been getting the same error message.

There’s definitely another bug in the script as it’s responsible for creating those multiple entries, each time you run it, it creates a new pair of entries in /etc/apt/sources.list

I’ve also seen an error “‘http://software.virtualmin.com/vm/6/gpl/apt virtualmin-universal InRelease’ doesn’t support architecture ‘amd64’”

Repo maintenance was announced here: https://forum.virtualmin.com/t/software-repository-maintenance/105331

This specific problem has probably been fixed, and I think the next revision of the installer will fix the multiple sources list entries problem (it’s harmless, though, and shouldn’t happen often, since it means install.sh is being run multiple times, which shouldn’t happen often).

Appears to have been announced on a private page that us mere mortals cannot see.

Crap. That’s what I get for trying to fix things. News category is visible again.

no problem Joe, the install script should works now ?

Probably. But, let me know what happens. (Run apt-get clean before.)

1 Like

OK, I’m testing to see if I can sort out why it’s still failing.


I have this same issue.
Glad i found an explanation to the problem since i was also struggling to solve it.
Will try again later when there’s some news on the fix

Repo problems are fixed. (At least, this specific problem is fixed.)


Installation completed without any faults.
Thank you Joe!

1 Like

@Joe Thanks, it works fine for me now. :slight_smile:

1 Like

Thanks a lot Joe, working

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.